Global Dimensions not finding values

Hi folks,
I’m hoping one of the resident experts can help me with an odd error please.
We’ve just gone live with BC for a customer, and the global dimensions aren’t working properly.

Any customer or item templates which have a global dimension come up with this error:
“The field Brand Code of table Item contains a value (COF) that cannot be found in the related table (Dimension Value).”
“Brand” is my Global Dimension 1 Code in General Ledger Setup, and I’ve inserted it on documents for ease of use. If I look up Dimension values, I can see the correct values are there.

I’ve checked the template and it’s finding the dimension when I set it up there, as is any of these records when I use the Dimensions action to set them. However when I try to create a record with a template it fails with the error above.

I imported the dimensions from a config package, and it all seemed to import fine, no errors - have I missed something critical?

Any ideas? I’m stumped…

Just to clarify - where I have added the Global Dimension 1 Code to the page using designer (or vscode), it doesn’t work - it doesn’t find the dimension values. I have tried removing the field and re-adding it, but no luck…

I’ve seen issues with importing dimension values before. Go into dimension values and delete the line for the code that is erroring out and manually insert it. Test your transaction to see if that resolved the error message.

Unfortunately I can’t delete the value - I get this error: “This dimension value has been used in posted or budget entries and is included in a dimension set. You cannot delete it.” Should I add a new dimension and run a dimension correction to the new values?

Is CFO Blocked on the dimension list. BC treats it as if its not existent when its blocked.

Hi Sydney,
The dimension isn’t blocked, and the dimension values aren’t either. I presume “CFO” was a typo? Let me know if I’ve missed something there?

I get this error when trying to create an item from a template specifying the Brand dimension code:

however, you can see the dimension and value are both enabled:

Hi @Hamish_Duff,

I’ve done something similar and is working properly, I have no error.

Global Dimension 1/2 Codes are fields that are filtered by 3 fields:

  • “Global Dimension No.” =CONST(1) or CONST(2)
  • “Blocked” = CONST(false)
  • “Dimension Value” = selected dimension value

Can you check if “Global Dimension No.” is 1 in the records you try to select in “Dimension Value” table?

If not, try to use “Change Global Dimensions” process in general ledger setup page to force this field to be filled. Use it twice to go back to the previous global dimension configuration.

1 Like

You are right that is a typo. I’m sorry I dont have much more for you when I see this its because its blocked.

Have you tried to build the Item card without the template to see if you drive another error message?

Thank you pjllaneras!
Running change global dimensions to clear the settings, then re-running it to add them back again has cleared the issue in test, I’ll run it in Prod after hours.

Thanks for your help - much appreciated!

thanks for solving this question!

1 Like

MLSDev Web Development: Building web-based applications, websites, and portals using front-end and back-end technologies like HTML, CSS, JavaScript, PHP, Python, or Ruby on Rails.