Unable to open any report in AX - error -No connection could be made because the target machine actively refused it

While trying to open any report in AX I am facing this error:

"No connection could be made because the target machine actively refused it “192.XXX.X.XX.8201”

and I have double checked that the windows firewall is turned off and in the report serevr settings of AX , it is pointing to the right report server (and all the details are correct, becuse when I calidated the settings , it gave me a success message).

What I identified is the port number I see in the error message is 8201 while AX config file’s wsdl port number is 8101.

I suspect this could be the issue…

But I am not sure how to and where to change this port number to pick 8101 instead of 8201.

Can anyone help me out here please.

Thanks in advance


Have you tried running the report from the reporting server site directly? Are you able to open it from there or not?

Hi krupa,

Thanks for looking into the issue. Yes, I have tried opening with both report manager URL and Web service URL and all the reports (whichever report I open ) display the same error message 'The ‘AX_CompanyName’ parameter is missing a value ', which I’m afraid is not the issue.


Hey what is the value for “permission set name” on the Report_Expressions_Default_Permissions in the rssrvpolicy.config file set to ? Probably it is set as “Execution”, if it is then change it to “FullTrust”

<CodeGroup class=”UnionCodeGroup” version=”1″ PermissionSetName=”FullTrust” Name=”Report_Expressions_Default_Permissions” Description=”This code group grants default permissions for code in report expressions and Code element. “>

Also try redeploying “BIServices” from AOT.

Hi Archana,

Could you please let us know if:

  1. You are able to deploy any report from AOT?
  2. Was SSRS DB reinstalled/ restored from any other location/ backup?
  3. Was SSRS reconfigured to connect to a different server?
  4. Is there any other IIS site configured with the same port?

I had received this error before and there could be many reasons behind this. I would thoroughly inspect the configuration, settings and setup.

Could you please Compile CIL?

Deploying any AIF services from AOT will start CIL compilations, So my above suggestion of redeploying “BIServices” covers that part. Probably the issue might have been resolved.

Archanae , if your problem is resolved --please close this thread.