Report error in Ax2012

Hi,
Ax 2012 running fine …But when open any report system gives following errors.
the window comes up asking for LoginName and Password. After giving loginname and password, it comes up with an error message saying “Only Integrated security is supported by AX queries”.

We are on ax2012, OS 2008R2, SQL 2008 R2 64bit distributed environment with hotfix DynamicsAX2012-KB2579565

will be appreciated your reply !!
Thankx
Nitin

Within Internet Explorer add the http-address of the Report Server to your “Local Intranet Zone”.

And then try again.

Thankx for the reply !

That changes i have done still the same error coming…is there any more suggestion.

What URL did you add?

http://{servername}/ or the full address to /reports and /reportserver? Because the first should be enough.

Can you try browsing to the address through internet explorer itself?

yes i am able to browsing dynamics-ax/ReportServer.

Do you use the same username to connect to AX and Reportserver-url?
And are you at the same server when opening the URL and AX?

yes

Is the SQL 2008 Reporting Services Execution account set to the bussiness connector proxy account?
After verifying, please do an IISRESET and restart the SQL Reporting Service. Alse validate the ReportServer URL within AX.

Looking forward to hear from you again.

Reporting services execution account & Business connector proxy account are same.

the steps which you suggested are followed still no success.

one thing i would like to bring in notice before installing Hotfixe/Cumulative Update 1
application was running fine and even it was not asking for credential.

Strange… The hotfix should not break anything at all.

Can you validate your reportserver url?

You have only one AOS installed in this machine?

Also tell me if you did backup restore from an AOS running on port 2712 to another database for the aos running on port 2713.

True i have two AOS one for Ax2009 and another for Ax2012 on the same server.

port for Ax 2012 is 2713 and for Ax 2009 default port 2712 . Ax2009 is running fine.

i have restored demo data backup from 6.0.947.0-contoso-SYS-RTM.bak file.

Good.

Now try two things for me. Try acessing and running a report from AOS AX 2012 when you have your instance at AX 2009 running. AFter that, try shutting down AOS 2009 and try again running the report.

What I expect - the error would change.

No there is same an error !!

I thought this could be interfering, but now not sure…

That’s exactly what i’m thinking.

Only thing that i can think of is caching somehow… You might want to try rebooting the whole server, is that possible?

Otherwise I (or we) should check at the environment ourself… No other way i can think of at this point.

Any update on this issue?

Hi,

I would like to share the procedure which we follow to resolved above an issue

  1. Unistall & InstallSQL Server 2008 R2 reporting servers

  2. Beforing installing ax reporting server extensions, installed CU 3 of SQL server 2008 R2 priorly uninstalled SQL server 2008 r2 SP1

  3. Installed AX reporting server extensions

  4. Configure Reporting server

  5. Redeploy ax reports through command to resolve the error

e.g Publish-AXReport –ReportName *

for the error “the dynamics ax folder not found on the reporting server”

  1. Re-configure SQL reporting server

now i am able to run both application on same server Ax 2009 & 2012 +with cumulative update.

[:D]

Regards

Nitin