SSRS Error


I was getting this error message in visual studio when trying to open any report from AX.

please help me to solve this problem

Thank you



I cannot read the error message…please write the message here or put a better image.


Hi Joao,

The error message is

“The Item ‘\SSRS Reports\Reports\Report Name’ does not exist in the repository. It may have been moved,rename or deleted.”

please help me to solve this issue.


Did you tried to deploy the report from AOT? There’s an error too?

I don’t know what you did when got the error, but can’t it be caused by a wrong AX configuration?

You can try to explicitly set one:

To Create a Specific Configuration for Reports

To create a configuration for Reporting Services, run the Microsoft Dynamics AX configuration utility as an administrator, and then click Manage > Save configuration as file, and give the configuration a name like Microsoft.Dynamics.AX.ReportConfiguration.axc. The file must be saved in the PrivateAssemblies folder in the Visual Studio IDE installation directory, like the following:

C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\PrivateAssemblies.

Copied from How to: Open Visual Studio with a Specific Configuration [AX 2012].

It was giving same error when trying to deploy from AOT. but report is available there.

Hi Martin,

Thanks for your reply. I have tried as per your suggestion but still I was getting same error message.



All right, another idea: Isn’t it a problem with version control? Do you use one?

mhmm…Did you checked the server parameters in “System Administration / Configuration / Business Intelligence / Reporting Services” ?

Hi Martin,

I have developed that report in AX 2012 R2 with VS2010, and trying to deploy same on AX CU4 with same version of VS. and it was giving error. Is that a problem with version incompatibility. and now what should I do to solve this problem.


Why didn’t you mention it on the beginning? Now your question is: How do I backport SSRS reports developed in R2 to R1?

I don’t know the answer; I’ve never tried that. You may try to take the same report in both versions, compare project/.xpo files and change your report accordingly to the R1 format.

Hi Martin,

I have forgot to mention that, sorry for my mistake. And I did compare my .xpo project file, but not able to deploy the report…

and thank you I will try to change the report according to R1 format.