Permission for Change Log

Our team is working at the clients place for onsite development. We have completed almost 70% of our customization here in offsite. when we tried to post a sales order or a purchase order with the CLIENTS LICENSE, the system does not allow us to post it stating an error “you do not have read permission to the change log setup table”. what could be the reason and how to proceed further. NOTE: The user has not purchased the change log Granule. Can any one help in this? its urgent. Thanks.

Hi Thrishna Whilst developing the site a user has turned on the change log - so the database you have installed has entries in the Change log set up table (even if it is now ticked off). You will need to delete the entries in this table as the user has no access to it but the system wants to access it. Also have a look here:

hi steven, Thanx a lot for your immediate response. but we checked all the relavent tables and all are empty. I have another serious doubt. can you please tell me if the following could be the reason for that error to occur. we had been doing all the customizations for this project with the temproary License which we got during our Training sessions at Navision headquaters held on may 2003 which had a validity period of 3 months. My concern is only with the Developers License. unfortunately since our technical consultant who had the developer license left our organization, we had to do all the customizations with the developers license that we had been given during our training that is by BACK DATING our system. Now, CAN THIS BE THE REASON BEHIND THAT error.I feel all the customization done with that license is not working with the clients license. can this happen ? If so then that could be a problem in going live. what can be done on this. Thanks.

Hi Thrishna I do not think that would be the reason, although I cannot be 100% sure. In the other posting the final suggestion is to put your license on the customer site, turn it off and turn it on again - but my feeling is that that wold “cause” this issue, so I am unsure. Perhaps the developers can help because the code will call the change log at distinctive points. Can you create a new database without the objects and then run a backup (Cronus) to check it is not a client license issue? Alternatively create a new database on the clients site without the objects, restore Cronus and see what happens then. my gut feeling is that an entry exists in the change log table - as it is being referenced, but then again it maybe an issue with your client’s license - I do not think that the license yo uhave used would in anyway cause this.

Check again the Table 402 Change Log Setup. I’m pretty sure you WILL find 1 record there. Remember that you must open the Table directly from Object Designer and delete this record. The simple action of accessing this Table from the Form in General Ledger, Setup, Change Log Setup will cause this record (the setup record) to be inserted. What caused the problem was that someone from the development team accessed the Change Log Setup Form, causing the setup record to be inserted. From that point on, unless the customer’s licenses includes the Change Log granule, the program will throw out a permission error.

Hi Thrishna I have had a look at the support site of MBS. The majority of all calls with this message were because the Change log had been activated whilst the database was under development - the solution was to delete all entries in tables 402 to 405. On a couple of occasions they requested the customer license where these tables were empty, and on one occasion they requested the database. It looks, if the tables are empty and the license is correct - you will have to report it back to you NTR [:(!]

In this particular case, I think it is clear that Thrishna does not have a valid license, and thus is not really able to ask MS for help. Navision make it pretty clear that a training license is for training, not for production. Thrisna can’t you apply for a developers license from Navision? It seems you wnt to training 9 months ago, so by now you should be ready. Once you have this, you can contact Navision for support.

hi steven and nelson, Thanx a lot. your previous suggesstions were exactly right and thigs are working fine. now i have another issue. the customer is currently using Navision 2.0 and he is upgrading to 3.60. His license has 100 Codeunits for which he has paid. now system says it does nt have any permission to the code units in those areas where we have created our own Codeunits ranging from 50000. but they have access to codes in forms and reports. They have not bought Application Builder. for making use of the codeunits is it necessary to have a application builder ? if so without that how can the client make use of the 100 Code units for which they have paid? I am wondering and i have no clues as why the system does nt allow the clients license to access the Codeunits. and how do i go about doing things then… Thanks.

you MUST develop your objects in the same number range that the client has purchased. Otherwise you will need to renumber.

We have had exactly the same problem today where the message ‘You do not have read permissions for the change log set up table’. Cheking this forum we went to G/L setup, Change Log Setup, Set up, Tables, Object Designer, Tables, select table 402, Run and although it appears that there are no records in the table try deleteing the record. The system reacted as though a record existed and all was well thereafter.

you need to go to the table designer with a developers license, and delete the records that you have inserted. navision warned you not to work on your clients live data base with your developers license, now you know why.[:(!]

Hi Guys, I have had the same problem with Change Log setup and racked my brain trying to find a solution. The database we had and customers license worked fine on a backup that was 1 month old but a newer backup caused the “you need read Permision…” error. Eventually found that there was a BLANK record in the Change Log Setup Table 402 , so deleted this “Blank” record and Problem solved. Must have been activated/de-activated by development between backups. So Happy to have this solved now.

Exact same problem here. Blank record in table 402! There was only 2 developers involved in this solution, and I doubt that one of us did activate the function, but it may be possible. Strange that we are so many people having the same error since the beginning of 2004… [?]


Originally posted by nelson
What caused the problem was that someone from the development team accessed the Change Log Setup Form, causing the setup record to be inserted.

I still think this is what happened. The thing is that all Setup Forms have this code in the OnOpen event: Form - OnOpenForm() RESET; IF NOT GET THEN INSERT; Even if you just open the Change Log Setup Form by accident, that will insert the setup record and make the error messages appear.

Hi All, I did had a problem like that long time ago and i’d reported to MBS but we can’t solve the problem, so what I did was to disable all cahnge log function, it’s just a few minute task to disable that function just using Developer toolkit to find out where that function exist.

don’t change the code if you can control your processes with correct data. doesn’t it seem more right ?!?

With Change Log, just the act of switching it on, i.e. make it active creates a log entry, this can be a bit of a pain if someone asks to see how it works and you use your license file and then forget to delete the entries afterwards. Cheers Peter