Navision Application Server and User Permissions

Following Scenario: The nas runs a codeunit. The codeunit runs a report. The report needs to modify a field in the “Cust. Ledger Entry” Table, which a normal user license obviously does not permit.

Normally this can be solved by giving the report (properties) the permission to modify the table.

Now, when the report is executed via the nas-user it seems that it does not work like that - the permissions given within the report seem to be ifnored.

1.) Is this correct or do I make some error

2.) How can I solve my problem.

Thanks for your help.

The license is installed in server ?

I hope i know what your are doing by changing Cust. Ledger Entry [:^)]

Have you tried logging into the client using the same “NAS” login and running the report? Do you get an error message, and if so what is it? Are there any error messages in the “Event Viewer” of the machine running the NAS?

Hi Tony,

There was a problem in version 4, that NAS ignores properties on a report, including margins, and also permissions property. It was corrected, I think in SP1. but just to be sure, if yo update Navision, just use SP3. So try it with that version, and it should work…?


Hi everybody!

Thanks for your answers.

1.) I have added a field to the cust. ledger entry table, which I want to modify - so no danger.

2.) We are still using Version 3.70, but it does seem that nas ignores the permission settings of the report. And yes, if I run the report manually with the same permissions as the nas user it works!

Any more hints? Is it possible that version 3.70 has the same problems in nas as version 4?

Is it a Windows or AD login?

The proper way to do this, is to modify codeunit 103, and then pass your value through this code unit.

Hi Erik,

it is Windows login (local windows user). Does this make a difference? AD login would also be possible…

If you are using a local Windows account, your server can’t authenticate you. You are probably using stored passwords when connecting to Navision, but I think NAS don’t use it.

hey just wondering if you managed to get your NAS working or if this is still an issue we can help resolve?


Hi Tony,

yes, I got it working now.

I have tested all the suggestions made here, but the only one working is to go through codeunit 103.

Apparently, even with AD logins, all the permissions set on a report run by the nas are ignored.

Thanks for all your help.