Nav debugger

I am having a problem with the Nav debugger. I recently got a new laptop that was used by another developer. When he used it, the debugger worked fine. I uninstalled 4.0 SP1 from the laptop and installed SP2 to use. I have other versions copied to use for clients that are not on the new version yet. I can not get the debugger to work. It starts but it shows no code in the window and all the options are greyed out like when you stop debugging. This causes a huge problem because when I try to close it, Navision still thinks it is debugging and calls the debugger again. I have to click the x to close Navision and End Task. Does anyone know what may be causing this?



On Mibuso there are several discussion about it. Try to uninstall and reinstall

Thanks for the suggestion, but I have tried that and it still does not work. I have also done a search on Mibuso and can’t find anything about this problem.

are you running firewall? It had happend to one of the servers and what I ended up doing is format the drive and reeinstall windows. Here are some of the threads



There are other ones. Just have to go through the search list.

Thanks for finding those threads. I swear I did a search and did not see these. I uninstalled Citrix and the debugger started working again. The bad thing is I need Citirx. I will figure something out there.

Thanks again.


I have it all fixed. I found a new Citrix client install, installed it and debugger still works. Thanks again for all your help.


I know, I am a little late.
But I wanted to add this: Once I had the same problem, I had the full install of citrix. I de-installed citrix and then installed ONLY the citrix-client and all worked fine.