Can not restart object server service

Hi All,

When i tried to login AX, It shown the screen like service is down. When i checked services, it have stopped and not running. Then i have tried to restart the service(MS dynamics AX object server) it shows the below error.


When i check the Event logger i got the below errors, :frowning:


Could any one help me how to fix this issue and start the AX service.

Many Thanks in Advance.!!! :slight_smile:

Check if the SQL server is running.

Hi Kranthi,
Yes the SQL Server is running. Could you please suggest some other answers…

can you confirm that you have enough space in sql and aos server?

Hi Kunal,
Yes we have almost 7 GB free in disk space in C Drive. Pls suggest… :frowning:

is there any changes in network or server side recently?
check if your aos service account has proper rights to open the sql server ,
ping sql server from aos server
check if your aos service account’s password is not expired.

Hi Kunal,
The ping happened from AOS server to DB server perfectly.
Is that a problem with AOS service logon account. If it is yes then kindly let us know how to resolve the same.

is this something working fine and suddenly stopped? then confirm if service account password has not been changed

Hi Kunal,

Thanks for your suggestion. The service have suddenly stopped and the service account password not changed, it is same only.

Hi Kranthi,

I have restarted the SQL server machine as it is not allowed to restarted the service.

So I have restarted the SQL server machine then the got issue resolved. [emoticon:c4563cd7d5574777a71c318021cbbcc8]

Thank you all for your suggestions!