User conflict error

Hi All,

I am getting this error message when i try to update the purchase order line.

“An update conflict occurred due to another user process deleting the record or changing one or more fields in the record.”

I tried reread, RecVersion method. But not working.

Please help me to solve this issue.

Once i got this error, It is coming continuously.

Thanks in advance,


how you are doing it?

you might be updating an old version of the record. The reread should work if you are updating through code.

If the table is deleted, no reread will help you. If it’s an update conflict, rereading and updating again should help - if you’re rereading the right buffer.

Hi Kranthi,

Thanks for your reply,

I am using the below code. I put this code in the class section. I am calling this class from the “Product Receipt form”.

update_recordset UpdatePurchLine
setting InventDimId = NewInventDim.inventDimId
where UpdatePurchLine.PurchId == LocalPurchTable.PurchId;

I have also used while select forupdate. That method is also giving the same error.



why are you updating the purchLine inventDimId, the approach doesn’t seems to be good.

Rereading this buffer won’t help you at all. First of all, where is the conflict exception thrown from? From the PurchLineType class?

Don’t forget that update conflict requires two different updates of the same record, therefore it’s not enough to look as one of them.

Hi Kranthi,

The customization is i have to create the batch id what that customer entered in the product receipt form.

So, I have to update the batch id in the product order line section and also in purchparmline table.

I really stuckup with this error.




Is it possible to get the purchline table buffer from product receipt form?

I think, if i got that table, it won’t display that error message when i update the buffer table.



Hi Guys,

I think the below code is working fine.

I am getting the table purchline buffer from purchparmline.

LocalPurchLine = LocalPurchParmLine.purchLine(true);

Thank you guys. I will check and update.


I’m receiving this update conflict error when I have 2 purchase order lines and I update the order a second time. So, using AIF, I update the first purchase order line with a serial number. Then I do another update and try to update the 2nd purchase order line with a serial number. The first update works fine but the 2nd throws the error.

I’ve debugged and I can see that the error is coming from the PurchLineType class. Any thoughts?