Unable to Install Navision 5.0 in Vista


We are not able install Nav 5.0 sp1 on windows vista business edtion

we are getting below error

" Error 1935 an error ocured during installation of of assembly component

help would welcome

Thanks in advance

Are you installing as administrator?

yes Dave, I have tried that possibilty too. but still not able to install.

Try with anti-virus turned off and if still no joy try re-installing your .NET framework

I’ve had similar errors on XP - I found removing and re-installing .Net framework corrected my issues

We just went live with our Navision 5 system. We only had your error message when we used the .msi installation.

We switched to the .exe (large) installation file from cd.

(Skipping the SQL agent).

This installation overcomes several update issues on computers. And please don’t forget the cpp prerequisite.


Wouter Stil

After I did a fresh install of Vista I had the same problem. Neither of the above suggestions helped me.

But instead I found this https://community.dynamics.com/forums/t/9325.aspx by our member DaveT:

This is a common error when installing NAV on Vista (and Windows Server 2008) x64

The x64 Redistributable Package is not included in the NAV setup and is not included in a clean Vista/Server 2008 installation but must be downloaded and installed before installing NAV.

…also check the name(s) of the directory(ies) (like “CSIDE client” or similiar) there is one installer package on the road which contains a wrong directory name(s)…

I was installing in the “normal” x86 version. Not 64 bit.

Thanks Eric. I was trying to install on Windows 7 and it wasn’t working and your link solved the problem.


how about the 64bit i have encoutered error 1935