SSSR Report visible in Visual studio but as empty in AX client after deployment

Hi All,

Pls help me with the following issue. I have been stuck with this for the past few days.

I made a new dataset for the SSRS report namely ‘WMSPickList_OrderPick’ and a new design too. The new dataset is being filled up by DP class which returns a temporary table(a new one for my set of fields). The required change has been made in the controller class too by calling my new design in the .initArgs method, and also in the output menuitem for the same.

I am able to view the report fully functioning in Visual Studio with all the data n all, but even after I deploy it, it is seen as empty one in AX client.

(Actually what I feel is that the data is not getting inserted unto the temporary table because it is showing a blank table there. But then how the report is seen in Visual Studio?)

What can be the possible reason for this??

Any help would be really really appreciated.

Thanks in Advance!!!


1.Apply debugger in processreport method and check whether data is getting inserted or not.

Delete all the records from Syslastvalue.

Try to generate full CIL then check once again.

Hey thanks for replying.

I checked it out with a debugger. Yes the records are getting inserted and this is the reason I suppose why they are being displayed in the Visual Studio which uses the same DP class. Actually for my customization I have added two new methods into the existing DP class. One is the initTempTable method which fills my temporary table, and the other is the getTmptable methos which returns the same. I have placed my initTempTable method inside the insetIntoTmpTble method.

I have tried out and generated incremental CIL too. But nothing helped.

Are passing the data as arguments to InitTempTable method?

Make your tmp table as regular table.add ttsbegin and ttscommit.So that you can verify whether data is inserted or not.

Yes Raju,

Data is being passed into initTempTable method. I confirmed it again from the debugger.

Table is already regular ad the DP class extends from a SRSDataProviderPreProcess. Where do I insert ttsbegin and ttscommit?? in the initTempTable method?

Tough to understand your problem.

Most of the problem was solved for me by restarting the ssrs.Still I am confused why we need to do that.

Start > SQL server R2 > Configuration Tools > Reporting Services configuration manager

Did you face the similar issues? I had restarted the reporting services. Let me see if it hepls

Anyways thanks a lot Raju.

Hi Preeti,

At one of customer sites, we had similar issue. SSRS report worked fine in DEV environment but when we deployed it didn’t work in test environment.

The issue turned out to be company logo was missing for this company (under organisation administration > Setup > Organisation > Legal entities). Loading of company logo and restart of AOS fixed this issue there.

Hope this will be of help.

It was truly like Wow!!! worked for me… :slight_smile:

Thanks a lot Harish and Saju.


Hi Preeti,

I am glad users from this forum were of help.

If you think posts such as this solved your problem please can you mark them as helpful? This will help others as well.