SSRS report not showing data

Dear All,

I am using AX 2012 R2.

I designed a report using RDP and facing very strange issue

I used two tables HCMWORKER And PayollJoining(customize) table in Process Report method when i run the Process Report method using a job for testing. it is working fine and showing the data from PayollJoining table and HCMWORKER

but when i run the SSRS report it is showing the data only from HCMWORKER table and PayollJoining table fields show blank.

Any idea ?

Any idea ?

Hi Ali,

Have you found solution for this issue.

Dear Sakthiananth,

I did one workaround i created a view of that table and SSRS works fine with view.

but i don’t know the reason why table is not working directly.

Let me know if you have any idea.

Please debug the RDP class to see whether right records are selected and whether the temporary table is filled in correctly. You can’t do much unless you find out where the problem is.

Dear Martin,

I run the RDP using a job and it is working fine but when i run it from SSRS the table doesn’t get the records.

but when i made a view for that table and run the SSRS the report showing the data in fields.

I run the RDP using job and it is working fine but when i run the SSRS it is not showing the data.

let me know is there any way to debug the RDP from SSRS ?

It is possible - find the description here: How to: Configure the Debugger to Debug a Report Data Provider Class.

Hi Martin,

I debugged it. Data to the Temp table are getting populated but that’s not returning to the report it seems.

FYI: I’ve removed all my customization on this report but still it’s not showing the data.

Please Help me out

I’m just working on your Idea Ali.

Sure I’ll let you know if I found some thing on this.

Hi Martin/Ali

While using View as a data source for my report instead of the Temp table “SalesInvoiceTmp” report is working fine but why can’t I achieve this using the temp table ?

I’m just sharing some thing what I found in the mean time:

I’m facing this problem after I added two fields in the “SalesInvoiceTmp” table from then my report is not showing any data on the screen(Now Even after removing my fields in the table also not helpful).

For test purpose I made an info dialog to display the records which are inserted to the temp table now I can able to see the data in the info dialog but when it’s SSRS report it’s not working this applies for both Visual Studio & Dynamics

Hi Martin,

Could you please help me out on this issue. I removed all my customized fields in the “SalesInvoiceTmp” table about 4 Fields. After this action the “Salesinvoicereport” in the VS is throwing the error like below even after restarted the AOS & SQL server, Generated Incremental & Full CIL generation, Sync the Data dictionary. Can you suggest some thing on this.

2211.Capture.PNG

Restore the dataset in Visual Studio & build the solution.

Hey Harendra,

Thank you for the reply. I solved the problem. I’m facing some other problem If could suggest me on that It would be greatly appreciated.

Please find the link below

http://dynamicsuser.net/forums/p/76065/417747.aspx#417747

https://community.dynamics.com/ax/f/33/p/128462/279327.aspx?WT.mc_id=ForumPost#279327

Please share the Report image

Hi Vinoth Thanks. Here is the empty output of the report “SalesInvoiceReport”.

Any Ideas Vinoth ?

Hi Sakthiananth,

Is it only one SQL report service instance is there ?

Hi Vinoth.

Thanks for the reply. Yes We’re having single SQL Reporting Services running on the machine…

Any clues ?