How to edit the Purchase order

Hai to all,

when am trying to create a new purchase order it is taking a number automatically like’ 000450’.up to now am ok.but suppose i deleted a existed record “000420”.Now i want to create a new purchase order with the same number 000420.

Is it possible or not ?

If you have set the system to automatically generate numbers you cannot, although you could rename it. If the asutomated number sequence is set it will fill in the number, but you could not specify an exact number unless it was manual.

Thanks adam,

Is there any possible way to set as manual ? if Yes how can we set as manual insted of automated.

This is for ALL purchase orders.

Go to the purchase ledger - Setup - Parameters - Number Sequence Tab.

Navigate to the main table on the number sequence field on the purchase order line. Set the Manual field =yes on the general tab.

Now you have to tell the system the number each time. Do you really want that?

Hi AdamRoue,

when ever i am enter the item number in the purchase order details form then unit price will be coming automatically and net amount will coming by the multipication of quantity and unit price how it will come?

It takes the prices from the Item Master or from the trade agreements…

how net amount will be coming by the multipication of quantity and unit price? is there any method

Thanks Adam,

Really i don’t need that a developer i have a small doubt eighter it is possible to change or not? anyway i got the option from u.

Now another problem rising after setting the namual also it taking the PO numner automatically and also givies the worning as Must fill the Vendgroup,Language Fields. i didn’t get any field in the creating of new PO.Plz give me solution

Hai kranthi,

i just checked the option what the adam told in the continious to manual.

then again i changed Manual to continious.Now am trying to create a new PO it showing 2 warnings Language must be filled in,Vendor group must be filled in .

But am not getting any option to fill the vendor group in that forn .plz give me suggestion

Then you want to change the number sequence if you want like that

The vendor you have selected does not have a vendor group or language set, set the vendor up correctly.

Hai ramya,

am getting warnings when am creating the new Vend group and language must be filled in.But i didn’t get the Vend group field in that PO form

Hai adam,

Am working on vpc only.before it is working fine and it is not asking any vendgroup or language.after i try to change the PO number settings continious to manually then onwards only am getting the warnings ,plz try to give me solution

See in the Administration group whether these details are getting filled or not…when creating po…

The number sequnce for the PO has no bearing on the other header information, the vendor group and language must come from the vendor as they are different per vendor,. as a test change teh number sequence back. If it works I would say you have had some development work done or you are doing something you have not yet explained.

Hai Kranthi,

in the Administration group Language and Buyergroup details not filled when am creating a new PO.i filled the Language by manually.But i didn’t found the field called **Vendor Group .**still am getting the same warnings

As already told these things will be defined at vendor level.

***What make you go for a manual allocation of PO numbers…It is suggested to go with an auto generated number sequence

kranthi,i set as automatic number sequences only.But it is showing the same warnings.i didn’t get any solution

You imply earlier in this post it was due to the number sequence setting. We told you it was not. Now tell us what else you have changed, because as you correctly state earlier, it was working, so clearly you have changed something, whether data or coding. Also describe exactly at which point the message is being presented, and post the message into a reply.