TCP/IP Error ETIMEDOUT when connecting to server

Dear all,

I’ve got a problem relates to setting navision database server anymore.
The error message written is “there was a time-out in an attempt to establish
a connection with the server (TCP/IP error ETIMEDOUT)
See the network documentation for additional info. Contact your system manager
if you need assistance”
I don’t understand why the error comes, I have set the hosts, run
server.exe, installasservice, license is good and database is no problem
Any help from you are appreciated. tku


Is this a new installation or you’ve had NAv for a while and this is something happening new.

Are you having network problems. Do you have a client installed on the server and does that open navision easily?

Eating some food before you do this task might help too

What version of Navision are you on? What are you trying to open when you get the message?

There was a patch for this when there are too many flow fields trying to calculate and the client would end before the response could be returned.

I have installed client and it can open navision easily. I have done also installasservice and set IP in the hosts in server and clients computer. there is also default gateway, I have unsinstall the server and reinstall, but still not success.

I am really confusing and stress where the problem is. This problem is new to me but beforehand, I have find out no problem.

Only in the server computer, the problem, but when I use my computer as a server place, there s very easy, not take a long time, I just need to set the server name when installing server, set IP in the hosts accordingwith servername, installasservice the servername, run server.exe then client can open and also my computer client can open the server.


It’s navision w14.00.02, I am trying to open database of navision database server. I can’t understand your explanation, I thought there maybe a setting in the network or hosts or protocol or services or anything not relate to navision itself.


Your suggestion is ok, but it was 11.30 p.m here when I post this message, I never sleep above 10. 00 pm. so the 11.00 was actually my sleeping time. I should be in the dreamland in the time.

Do you know the solution then…?


Okay lets start with the basics. Have you got the installation guide and read it? it comes in a PDF format on the CD.

  1. Try the following ON the server. Set the services name to some name different to the physcial domain name of the server. Something like <NavisionServerOne> then adjust your Hosts file again to match. Click Start → Run. Type CMD, in command prompt type PING NavisionServerOne - Just making sure your network is working right. Do not use the IP address . If that does not work then there might be an issue with your network. A firewall somewhere or maybe even a sub-net mask issue.
  2. Make sure the IP address of the Server is not DHCP assigned.
  3. Having tried all of the above, and assuming you’ve not changed it back. Go to the services file. Add a new line. NavisionServerOne 2411/TCP. Then try running the navision client from the Server and connect to the database, Making sure on the advanced tab you have selected TCP.
  4. If that works, go a client machine open navision and use the database → open. servername <IPAddressOfServer>:2411 see if that connects. Making sure on the advanced tab you have selected TCP.
  5. If 4 works then setup hosts and services on the client machine. As discussed above. Test again, if that work then your all working.

If none of that works then hit us back!


I am very exciting with your reply however I will try first and let know. I have read the installation guide but nothing work good. I have satisfied very much to read it.

No. 2 is correct, it is DHCP, address type is assigned by it. however, it is in my computer (notebook), it’s no problem when the server installed in my computer. The client is able to access the database (fdb file in the server).

No. 3 is not used by me. I just use hosts then in all client computers I assigned IP and the servername existing in my computer, but using this way in the original server computer (CPU), I add servername and IP in my computer and client computers hosts that owned in the d**ned computer, I can’t access the database. The procedure of installation according to the pdf file has been done, uninstall-reinstall, change servername-renew servername, adding TCP in service, still not work.
Do you mean the server name as you wrote servername :2411 is IP address? so when I install the server, its name is x.x.x.x, isn’t it ?. I am still not understand. What about static IP…? will it be possible a barrier in the connection between client and server…?

Subnet mask is also available but it’s applied to all computers, isn’t it…? Firewall is not active. I don’t also use it’s localhost. If I use DNS, I think I will not use service ??? TCP is set when install/select and when open the database too.

anyway, when I ping in the command.exe window, why must I use navisionserverone…? it should be shouldn’t it…?
I am really not understand…but I will try…



I think you’v confused me more than I confused you. LOL!

yes when using the :2411 I mean as in something like

Where is in fact the IP address of your server.

the reason you are pinging with the navisionserverone host name is to make sure that it sends packets to the server you specified in the hosts file, if its not setup right you should get an error.

Let me know your results.


I’ve used this with success
Navision Database Server Setup Wizard v1.01

Hi Savatage,

I have had the file but not work. It maybe relates to networking problem, I am currently out of office for 3 days so what Tony has suggested can’t be applied yet. The stressful statement is why the time-out happened.


Hi Tony, All,

I have moved to other computer that has been assigned as server, so the computer that made problem has lefted. It means that the problem is still flying around. In the new computer, I find nothing problem. But the new problem is arrising now when want to start the server, I must do this following steps:

  1. Run command.exe
  2. c:\cd program files
  3. c:\program files>cd microsoft business solutions-navision
  4. c:\program files>microsoft business solutions-navision>cd database server
    5.c:\program files>microsoft business solutions-navision>database server>server.exe (after did installasservice)
    then my server is running and can be accessed by client in other computer after do the above steps.
    When go home, I must press Esc and Enter

Could you let me know how to skip the above mentioned step…? I have tried to download one of the mibuso forum moderators sugestion (he posted it and I downloaded) but not work. I appreciate your answer very much. tku




When you type “server.exe”, you are telling the Navision server to run as a task in the current command window. Instead you need to install it as a service, and then start the service.

So do the following :
1/ open SERVICES from the control panel,
2/ find the Navision server service
3/ If it is not there, then at the command prompt type server.exe installasservice
4/ Go back to services
5/ Now locatet eh Navision Server Service
6/ Hit the start button.

Basically what I think you did, is that you installed the service, but did not start it.

Hi david,

Tku for that but I am very satisfied with your sugestion, I mean I have done that but fail. i am not in the server now so I can’t post the error message said. I have done installasservice, I have seen it in the services located in the administrative tools of control panel.but [:(] dissappointing…



Andreas, please read my post, follow all the steps, and then comment. As I said, I think YOUR mistake, is that you have not started the service. This is something differtn to installing the service. In reality this is not a job you should be doing, it shoudl be done by your IT department, it does need some basical Windows Server knowledge.

Also please try to understand, Dynamics NAV is not word or excel, you really need proper training before you try to work at the level you are aiming at. OR if you can not get to training, then at least stop blaming Navision and Microsoft for the fact that you havenet been to training, and are doing things wrong.

We are all here doing this work for free, you probably have guessed that you have not sent any money to Erik for running this site, nor to Steven for all the great help he is giving you. If you don’t watch your toungue, then that free help is going to dry up.

Sorry to be so strict, but we are all trying to help you, please juet be a little friendlier towards us.


If you complete the steps mentioned by David succesfully, you shall see a message in the command prompt that says “Succesfully installed as service”.

I cannot remember completly off hand, but I think if you just run Server.exe from the folder with out having used the Install wizard you may find that it does not put “Microsoft Business solutions-Navision” at the front of the service name.

And, the other thing to bear in mind is that if you can start the service in command prompt by typing “server” you should be able to find if other computers can connect to your service from the network.


Hi David,

I have done no. 5 and 6, but I must still do the steps I have written. I am very distressful. How to avoid the command.exe…?


At this point, I have no real idea what you have done and what not. I suggest you completely uninstall the Navision server and reinstal again from the Install CD.