Role center error in home page

HI all,

i assigned CFO role for my login. In home page it shows error as :

"the general ledger cube cube either does not exist or has not been processed"

so, i tried to deploy cubes and i checked the process check box. It shows error like:

If anyone know the solution please reply me.



Internal error: The operation terminated unsuccessfully.
OLE DB error: OLE DB or ODBC error: Login failed for user ‘CETAS\AX-SERVER$’.; 28000.
Errors in the high-level relational engine. A connection could not be made to the data source with the DataSourceID of ‘Dynamics Database’, Name of ‘Dynamics Database’.
Errors in the OLAP storage engine: An error occurred while the dimension, with the ID of ‘DATE’, Name of ‘Date’ was being processed.
Errors in the OLAP storage engine: An error occurred while the ‘Year’ attribute of the ‘Date’ dimension from the ‘Demand Forecast Accuracy initial’ database was being processed.
Server: The current operation was cancelled because another operation in the transaction failed.

Dear Satish,

Are you able to fix the above error.
Even I am getting the similar error.
Pls. share your solution.


did you try to update your analysis project with date dimension?

To add the new date dimension to an Analysis Services project

  • Click Tools > Business Intelligence (BI) tools > Analysis Services project wizard.
  • Click Next. Click Update and then click Next again.
  • Select the project to which you want to add a Date dimension and then click Next. After the Analysis Services project is verified, click Next again.
  • Select the perspectives that correspond to the cubes to which you want to add a date dimension.
  • Click Next two times.
  • Select the dimension you created and move it to the Selected pane.
  • Complete the Analysis Services project wizard

Hey Mazherullah,

This error message is indicating that the process, which pulls data from the AX database and into the SSAS database, is failing due to insufficient rights.

It looks like something doesn’t have permission to the AX database. It might be the service account that you’re using the run the analysis services service on the box with SSAS installed. Take a look and make sure that has access to the AX DB.


Hey Kunal,

I think the errors about the date dimension and stuff are just the steps that were processing when SSAS determined it didn’t have sufficient credentials. Once the get the correct access to the AX DB, there shouldn’t be any problems with the date dimensions.


Yes you are right Jake, for connection issue it can be no rights for current user

below steps can help to resolve this error

  • Double click the data source in the Analysis Project Click
  • Impersonation Information tab
  • Select Use a specific Windows user name and password
  • Enter user name and password and click OK
  • Process the Cube

Hi All,

Firstly, its not Deploying the Dynamics AX database in Analysis Service…Only after that I will be able to Process the cube.


Still look at the credentials of the service account against the AX database.

Hi Jake,

Its AXadmin which has Domain Admin privilege


can you please tell us the steps you are following

  • also can you confirm on analysis server setting you have correct server and you makr it as default? (System administration > Setup > Business intelligence > Analysis Services > Analysis servers)
  • are you able to see the database name in the olap database tab?
  • also when you connect analysis server in sql , what you are able to see , is there any database there?


Kunal Patel

First I installed AX DB and AOS.

Then installed SP and EP.

From AX Setup installed EP and Analysis Service

From Ax - System Administration screen - Checked the Analysis service

  • made as Default. Then from Tools - Business INtellegence… Analysis Service Project wizard

=== I was able to deploy other two database but

=== Dynamics Ax db deploy error

  • are you able to see the database name in the olap database tab?
  • also when you connect analysis server in sql , what you are able to see , is there any database there?

Yes, thru Analysis Project Wizard I was able to deploy “Demand Forecast Initial Database” and that is listed under OLAP Database,

thank you for your prompt information

are you able to see dynamics ax database under olap database tab
also in sql server, if you are connecting to analysis server ,are you able to find anything there?

also please specify your ax version


AX 2012 r3 Cu10
DB: Sql Server 2014 Standard Edition (64bit)

As said, Under OLAP Database it list only the Deployed ones. But when u want to deploy under Analysis Service Project wizard. Under the list it shows DB including Dynamics AX.

If connectiong to Analysis Service, only the deployed ones are listed.

Note - Just for information
-Before the Ax was in other domain. And we didn’t tried Analysis Service/Role Center during that time.
-2 weeks back we moved the AX to New Domain.

Today I also removed Analysis service and EP component from Ax setup
Also removed Analysis Service from Sql Server 2014 database and re installed and tried . Still the same issue.

The user axadmin thru which I installed AX, DB, EP, SP has domain admin privileges.


please confirm following things

  • your BC proxy account is set properly in system service account
  • axadmin has been added in the analysis server in sql management studio
  • add axadmin in the anaysis server of sql configuration as well, see below screenshot

dont use tranlation when deploying cube for now.

follow below sequence

  1. Select the Deploy option
    • Accept all the defaults
    • You do not need to select the process option.
    • Run the Project wizard again
  2. Select the Configure option
    • Do not add any translations
    • Do not process
    • Run the Project wizard again
  3. Select the Update option
    • Do not add translations
      Do not process

Thanks…but didn’t worked sir.

My options as follows


try to use axadmin there
same error when you tried to deploy without process?
which is this db : DAPCube Intial?
i can see you have two instances of the sql , please confirm it is not because of you are selecting wrong instance somewhere