Process Allocation Request - No records found on the source

Hello Gurus.

I was testing my ledger allocation rule and put up the necessary values for souce and destination. I checked the source ledger account and the corresponding dimension set heirarchy values. There are several ledger transactions on the particular source ledger account before I performed the process allocation request.

After performing this process, the infolog showed this message " No records found for **** source. I believe the system refers to the ledger account I assigned at source, right? If yes, why did it not process? Is the allocation process good only for ledger transactions made after the ledger allocation rule is set-up? Or did I miss a crucial step here?

Thanks for reading my case.


Yes I believe allocation rules only apply after the rule is set - post a journal to verify your settings. Posted transactions stay unaffected, you would need to manually reassign these if required.

Hi Del, I have the same problem. Have you found a solution to this issue or is this a bug in the system?

I have created a dummy account and use this as the source account and it worked well. I tried to compare the settings of this new account to the one I previously used and the settings are the same. I don’t know where the problem is. Did you encounter any anwers since then?

Many thanks,


Hi Del,

I guess that your problem is in the source values since I got the same message. I solved it by adding new filter values for each dimension.


Hope it helps!