Enterprise Portal

I am using 64-bit machine and have installed AX 2009 SP1, sharepoint 3.0 sp2 and ep. But I have issuse to Manage Deployments AX 2009>Administrator>Setup>Internet>Enterprise Portal>Manage Deployments>click Manage Deployment cannot be run because Enterprise Portal is not deployed on this computer Then I tried AxUpdatePortal utility also but till i have that issue what I want to do Thanks Gajendiran

In AX check the following:
Administration → Setup → Internet → Enterprise Portal → Websites.

Is there an entry with a URL to the EP site?
And did you install the EP and Role Center Role from the installer?

Yes, I have checked Administration>Setup>Internet>Enterprise Portal>Websites and click the button View History this site can be view http://rndserver/sites/DynamicsAx/Enterprise%20Portal/EPDefaultRoleCenter.aspx?WCMP=DAT this site will be load and displayed all data. But in the form there will another issue when click Create Site button there is issue. MS Dynamics AX cannot create site because windows sharepoint service is not installed on this computer. I installed WSS 64 bit sp2.

But till I have the same issue…

You have installed WSS on the machine where you start AX?

Try removing the URL from websites and “Register” it again.
After registering run the following command in CMD (use evaluated permissions = Run as Administrator):

CD C:\Program Files\Microsoft Dynamics AX\50\Setup
AxUpdatePortal.exe -updatewebsite -iisreset -verbose

Look at the LAST LINE of the messages, does it say SUCCES or FAILED?

Hi Patrick, I have tried this it will be displayed C:\Program Files\Microsoft Dynamics AX\50\Setup>AxUpdatePortal.exe -updatewebsit e -iisreset -verbose AxUpdatePortal [ -updateWebSites ] [ -iisreset ] [ -verbose ] C:\Program Files\Microsoft Dynamics AX\50\Setup>

I’m sorry i made a mistype in my command, it should be:
AxUpdatePortal -updatewebsites -iisreset -verbose”.

Please inform me about the output.

ya, Success then…

Hi Patrick, Till the same issue is displayed…

Then the deployment is succesfully done. So you should see all EP components and forms.

Then the Home module is not displayed

Then you should run the following query in SQL.

USE [databasename]

SET [DESCRIPTION] = ‘Finished’

Then you should run the follwing query.

USE [database name]

SET [DESCRIPTION] = ‘Finished’

Still I got same issue and the home module is not displayed

Is the Business Connector pointing to the right AOS?

yes I will running the AOS in the single system


Patrick thanks for your reply But till i have same problem, Help me out

Hi All,

  • I have successfully installed Ax 2009 SP1 in Windows Server 2008 R2. I have also installed EP and role center successfully. I was able to open the default website which got created while installing EP.

  • But When i try to create a site from " Administration>Setup>Internet>Enterprise Portal>Websites> create site" I am getting an error message " MS Dynamics AX cannot create site because windows sharepoint service is not installed on this computer"

  • When I tried to deploy the site using “Administrator>Setup>Internet>Enterprise Portal>Manage Deployments” I am getting an error message "Manage Deployment cannot be run because Enterprise Portal is not deployed on this computer "

  • I Tried to run the command " AxUpdatePortal -updatewebsites -iisreset -verbose" from command prompt with the directoryC:\Program Files\Microsoft Dynamics AX\50\Setup"

Then I Tried to run the command "C:\Program Files\Microsoft Dynamics AX\50\Setup>AxUpdatePortal -updateWebSites -verbose > “C:\EPUpdate.log” It also success and in the “EPUpdate.log” when verified this message Identified:

Entering function Is40WPPackageInstalled
Microsoft Dynamics AX 4.0 Web Part package axwebparts.cab installation status False
Leaving function Is40WPPackageInstalled
Leaving function Remove40WPPackage

But I installed AX 2009 sp1 how to solve it…

But Still I have the same problem…

Can Someone help me in this…


Hi gajendira,

today when I was installing AX, I have the same problem,

how you resolve this?


Hi all, I encountered exactly the problem as above. I would like if it is a setting problem? How to solve?