You do not have the following permissions on Table [TableName] : Execute , Page Edit [TableName] must close.


I just tried creating a new table in the object designer and when i click run in order to view it or enter data it says to me ,

You do not have the following permissions on Table [TableName] : Execute , Page Edit [TableName] must close.

I tried restarting the server , after uploading the proper license as well.

P.S - I have SUPER user permission

please let me know the solution.


Hi Asad,

Are you sure that you have access to the object number you’re assigning to you table? When you assign numbers to an object, you need to have permissions to the number first. And this might be different from license to license. If you have a partner license, then you can use all numbers from 50,000 to 99,999. If you have a customer license, then you can only use the object numbers assigned to you by your partner (as per your purchase).

You can read this blog post about the NAV tables and objects.

Hi Erik,

Thanks for the prompt reply.

I do have access to the object numbers. Because while creation of the table I am not facing any problems , as the table is created. But while I click RUN button in the object designer , when the focus is set to RTC , in the RTC it shows this message.

I have the required permissions as far as I can see.


I am not able to see the image which you have attached.

You can create a list Page with Table “License Permission” using Wizard to check what permissions your license has.

Hi Mohana,

Thanks for the reply.

An excellent idea , but I cannot even view it as any new page creations are not being shown. Let me attach the picture , might clear the problem.

Which Version are you using?

What is the Page ID you have created?

Are you using Standard Super role?

Check whether you have Read and Execute Permissions on your role?

Did you contact your Partner to check the License?

You said your problem is only on the RTC client?

You didn’t say which version you’re using, if it’s NAV 2009, then you should be able to run the table directly in the classic client. If you can run it here, but not in the RTC, then the problem might be that you’re using a different license on your server, than the one you’re using for development.


Using NAV 2013 , The page ID is 90000

Using the super role.

I do not know how to check whether I have the read and execute permissions , all other pages and tables open except this one which i created.

Erik, you mentioned that I might be using a different license on the server than the one I am using for the development. How can I check and make sure that the licenses of the server and development tool are the same. I do know on the development environment to check for the license , But how about the one on the server?

I have just started learning NAV and thus have no idea about things and thus such silly questions I assume.

Thanks everyone.


You are right, I just checked my licensing information for RTC and YES it does have a different license than the one for the dev. tool. Can you please tell me how I change the license for the RTC.

Also are they any good resources to check out for such queries ?


You need to UPLOAD license from Development Environment.

Tools–>License Information

and Upload correct license.

Restart your Service and Check


Tried that multiple times with restarting the server. Doesn’t work. The license on the RTC still remains different.!

Thanks Eric and mohana!

I found out the problem to be in the database permissions and thus even When I was changing the license through the shell , it said access is denied and that is how I got the idea. Works now.