Workflows are not working and AOS crashes frequently

Hi All,

The AOS keeps crashing and workflows are not working which are related to the AOS…

Can any tell me how to process with this and suggest me to solve this issue…?

Thanks in Advance…

Have you checked in the event viewer?
What do you mean by workflows related to the AOS?

The workflow message processing batch job is in executing state for some time and due to this batch server crashes.
If i did not run the workflow batch job, batch server is working fine.

I also checked for Deadlocks and Event viewer. There is no deadlock. and no errors in EventViewer.

I have been also doing some analysis on the SysWorkflowMessage Table. And tracking it with WorkflowTrackingStatus table i found the error in the workflow. The Owner is empty. This Owner(AX User) has been removed from AX.

After i specified new owner to this workflow. The batch job started working fine for 1 day.
Then again the same issue happens.
Checked all the worklows. Generated FULL CIL. Restarted all the AOS’es services.

Hi All,
Any suugestions…?

Crash could have been logged in the event viewer. Have you checked the log on the batch server and AOS?

I have checked the event-viewer I got the following error.
User ‘abc’ is not authorized to select a record in table ‘CustPastDueOpenBalanceView’. Request denied.

Is that causing the crash? Have you tried by providing necessary permissions to that user?

Hi Kranthi,
I have provided the necessary permission to that user and it still not working…Two users removed form the AX and AD…

I couldn’t able to debug because after submitting the workflow(Ledger journal daily workflow) the AOS crashes…

Have you tried this for debugging?…/dd638052.aspx

Hi Kranthi,
Thanks for you reply.Issue solved…Calendar period is not activated and the workflow uses the working calendar…It was the issue.The issue is resolved after changing the calendar setup…