Workflow assignment error.


I am getting following error while assigning user in the workflow. :

Failed to create a session; confirm that the user has the proper privileges to log on to Microsoft Dynamics.

Urget reply would be appriciated.


Are they setup as a user of AX? The error suggests they are not.

how it can be done? Please explain.

What create them as a user in AX? - Look at the common forms in Administration and create the user, then in the user relations link them to the user.

Hi Abhishek,

Did you manage to solve this problem? I have got the same error.
Your help would be really appreciated!


Do you have correct setup of workflow accounts in Administration > Setup > Security > System service accounts (if you’re in AX2009)?

I believe that I have found a solution to this problem. For me, the problem occurs when a user who has been in any way ever associated with any record related to the workflow is no longer enabled. The system then attempts to make a notification to the user, even if they are not immediately associated with the workflow. You then get this error message.

The solution that I’ve found is to modify SysWorkflowEventDispatcher.resolveParticipant to only add enabled users. That seems to completely eliminate this problem. Hopefully this helps!

This error is confusing, because it suggests a permissions error but can also be a case where the user does not exist. I solved it by updating the appropriate workflow settings.

The place I encountered this was in the Purchase requisition workflow in the Contoso company.

Here are the steps I took to resolve:

  1. When you encounter the error, take note of the Workflow Id and make sure you’re investigating the correct workflow. One of my issues was I thought the default workflow was running, when in fact it was not.
  2. Go through the workflow in question and check any assignments being made. In the case of the Contoso purchase requisition workflow, the workflow was using a workflow queue. That workflow queue was assigned to a user that doesn’t exist, because we have deleted all the Contoso users from AX. (Just set all the workflow assignments to “Workflow originator”.)
  3. Activate the updated workflow and resubmit.


Hey Brian is there any way i can get in contact with you> i saw you had a solution to a problem i’m currently experiencing.

Hi Shawn,

The fix I proposed will only work in version 2009. I’m not sure if it still occurs in AX 2012 or not. Basically, where it is selecting the users, you need to also check to make sure any user it would assign the workflow to for approval is active. I don’t have an AX 2009 environment at the moment, so unfortunately can’t give you anything more specific than that.

Did you ever find a solution to this?

Thanks Brian,

I am using ax 2009. I was wondering if you could send me some more details on the class you modified ? eg what code changes were made.