Using filer to exclude description containing 'word' and 'text'


I’m kind of stuck here, and I can’t seem to find any answer to my question. I found some answers in here, but all I can find is things related to numbers.

Anywho, in ‘item list’ I have loads of items with various descriptions.
I know how to only show the ones containing ‘word’: @word
But how do I exclude all the items containing ‘word’.
And how do I exclude all items containing ‘word’ and ‘text’

I have tried <>word, !word and can’t think of any more?

Btw, all this is related to using the filter on [description].

Thanks in advance!

Hi Cecilie,

I’m sorry, but that’s not possible in NAV.



Ok, I just have to it the hard way, through excel… You wouldn’t happen to know how to do it there without going through it all and deleting it line by line? :slight_smile:


In Excel you have a filter option called “doesn’t contain” (I’m not sure how its called in the english or norway version, I just translated it form german version :-)). I looked this up in Excel 2007 but it should work in older versions also (I think).

I’ll try that. Thanx :slight_smile:

Have a good day[Y]

You too…


the only way I am aware of to do this in Navision is:

  • Apply filter <>@word
  • Edit → Toggle Mark all items
  • Apply filter <>@text
  • View → Marked only

try this: <>@word&<>@text

Have you tried it? Replace word & text with any letter to test.

<>This&<>That works fine if that’s the entire contents of the field.

I tried this in customer list as: <>@* bhd*&<>@co and found OK.

Must be a SQL vs. Native Then. In Native no way that’s working, & we use Marking.

Good To Know.

Yes it’s on SQL bcoz Help file for Entering Criteria in Filters says <> (not equal to) is

The SQL Server Option allows you to combine this symbol with a wild card expression. For example, <>A* meaning not equal to any texts that start with A.