Unable to submit the workflow after Recall


I am working in ax 2012.

I have a problem with purchase order and purchase requisition workflow which has been already canceled (Recall) but still, it shows action button and unable to submit it again. Please help me what is going wrong here. Please see the below screenshots for further reference.

And also I have certain workflow instances in which I want to find which company they belong too. I checked in workflowtrackingsttausTable the contextCompanyId is empty. Hence with the help of configuration number, I checked in WorkflowTable dataareaID was also empty. Is there any other way to find which company the workflow belongs to.


  1. Have you tried to debug? \Data Dictionary\Tables\PurchReqTable\Methods\canSubmit
  2. What is the workflow type? May be the table on which workflow is running is not a company specific table.

I created a new PurcReqLine and tried to submit it and I got the following error,

One or more accounting distributions is missing a ledger account. Use the Accounting distribution form or the Posting profile to update the ledger account.


I solved the previous error. But Still I couldn able to submit. On creating a new PurchReq and when i try to submit, the workflow throws the following error,

Failed to create a session; confirm that the user has the proper privileges to log on to Microsoft Dynamics.

Check this,

I cleared that error still I am not able to submit it. the status is cancelled but it displays only action button instead of submit.

Try debugging and see what is happening in this methos, Data Dictionary\Tables\PurchReqTable\Methods\canSubmit

I couldnt able to debug as I coudnt able to take any further action as it is cancelled and not showing submit

You don’t have to do any action as such. Place a break point in that method and select the record in the form.

I also have the same problem in General journal also can you please help where to debug for General journal


I am getting this error on running the Tutorial_workFlowProcessor form,

Hi Kranthi,

Thanks for your reply…The problem is value of the field LedgerJournalTable.WorkflowApprovalStatus is not ‘NotSubmitted(Draft)’ and i had upadted the value to NotSubmitted. Now I can able to submit the workflow.