Unable to run Full CIL Ax 2012


I am unable to Run Full/Incremental CIL in my Ax 2012 environment.

Have Tried Almost everything But Did not get any success…

Getting the following error :-

Access to the path ‘C:\Program Files\Microsoft Dynamics AX\60\Server\EIAST_AXDB\Bin\XppIL\xml\AppObjects1.xml’ is denied.

Please help.

What if you try to delete the file from Windows?

Hi Martin

I have Deleted all the files from XPPIL folder lying on my AOS,deleted files from Sql i.e SysXPPAssembly Table then, when i restarted the services & did full compilation through Ax build method in Command Prompt,the files supposed to be generated again but they did not.

When I tried to Run Incremental/Full CIL, I got the above error.

Which files are not generated? AppObjects1.xml? In that case, does AOS have permissions to write to the folder?

The issue has been resolved Martin. The root cause was that the AOS execution account does not have the rights or permissions to write.I added it in the local administrator group & it worked. Thank you so much for your great help sir.