Unable to Log on to Microsoft Dynamics AX 2009

HI All,

I am trying to open the AX client in my local system it says “Unable to Log on to Microsoft Dynamics AX 2009

can any one help me how to solve this problem.

Thanks in advance.

Hi Sravya,


Please go through the above link… if it doesn’t solve the error…

Just go to the event viewer and let me know the message that You observe there…

Hi Chaitanya,

Very thanks for your quick reply.

I have changed my password but no use facing same problem.

Hi Sravya,

Are you able to log in into OS? Which version of AX your running? check your AX services are up & running. Click > start > Run > In run command prompt type services.msc. If your running AX 2009 , check Dynamics ax object server 5.0 is in started mode or not? if not right-click > start.

If your running Ax 2012, check Microsoft dynamics ax object server 6.0 is started or not? if not, right-click >start.


Hi Sravya,

can u check the event viewer once and see the error message that it is showing…

Hi Sarathy,

Thanks for your reply.

My OS is Windows 7 Professional, my ax version is 5.0 or ax 2009 and my AOS is running properly, he other clients are working fine.

me only facing “Unable to log on to Microsoft Dynamics AX 2009” error.

Can you plz give a right solution to rectify this.

Thanks in advance.


U only facing the problem or all other client also facing the same problem


The event log is:

The description for Event ID 103 from source DesktopCentral cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event:

Desktop Central Server is not reachable from this computer. Check whether any firewall is blocking the communication or if the Server is down.Configurations deployed will not be applied to this computer till the server becomes reachable.

The specified resource type cannot be found in the image file

Thanks in advance.

Hi Vinoth,

Thanks for your reply.

Me only facing the problem.

Thanks in Advance.


did you tried to resolve the issue by checking the services? that error will come when services are down. check once again and share the screen shot where exactly your facing issue or got stuck.

HI Sarathy,

Services are working fine. Check the screen below:

Thanks in Advance.


it may be problem with firewall setting .disable your firewall setting and check it out.

Hi Sravya,

this might be due to SID…

Just go to user info table in the database… and update SID for your user…


this might help you to understand about SID…

Get the SID number… for your PC through command…

Thanks for updating for error…now i changed the setting and easily able to access…

Dakota Medical Foundation

marcus wrote the following post at Mon, Feb 25 2013 9:35:

Thanks for updating for error…now i changed the setting and easily able to access…


How did you got the solution can you share it.

I am unable to solve the problem.

Thanks in advance.

Hi shravya,

have you tried to update the SID… in the database for your user…

Hi All,

The event viewer display the following error:

Faulting application name: Ax32.exe, version: 5.0.593.0, time stamp: 0x4831b016

Faulting module name: ntdll.dll, version: 6.1.7600.16915, time stamp: 0x4ec49caf

Exception code: 0xc0000005

Fault offset: 0x00051e86

Faulting process id: 0x340

Faulting application start time: 0x01ce0a817d214890

Faulting application path: C:\Program Files\Microsoft Dynamics AX\50\Client\Bin\Ax32.exe

Faulting module path: C:\Windows\SYSTEM32\ntdll.dll

Report Id: e9e2701e-768f-11e2-abf4-0024e81aa2aa

Thanks in advance

Hi sravya,

Have u tried by changing the SID… for your user…

please check the user whether he is in the ax users list or not ??

please check the user is in the dynamics or not