Unable to Edit a Customer Address/Delivery Address


Much appreciated if anyone could advise on the following.

One of our Users is unable to Edit a Customer/Delivery Address. He could carry out this function last week but unable this week. I have looked into his User Roles Assigned to him and these have not changed. What is assigned to him should allow him to edit an address.

What does “unable to Edit” means? Are fields read-only for him, does he get some error or what?

Does it work correctly for other users with the same roles?

Does it behave the same from all computers?

It would appear he is the only one.

He goes into Project Management & Accounting > Common > All Projects > Selects the Project > Then goes to Address Fast Tab. Everyone else has Edit button, Clear button & Map button. This user only has Map. It is like the other buttons have been hidden but unsure how to retrieve these back.

Maybe they have been hidden. Let him right-click the form and look for Show >. He might find the controls there.

A more radical approach is resetting all personalizations of the form (which can resolve other causes too). Right-click the form, choose Personalization and click Reset. Then restart the form.

I have tried both and neither work. Show/Hide only seems to work on the Fast tab itself and not the buttons just under the fast tab.

I have even tried a retrieve from user from someone that can see the buttons but this didn’t work either.

When you go into Persinalisation > Body > DetailGroup> CtrlTabForm > Address > Action Pane > ActionPaneTab > ActionsButtonGroup > He only sees Map whereby everyone else has Edit & clear there aswell.

Could there be some kind of a setting elsewhere which is having an effect on just this user.

There is still an open question: Does it behave the same from all computers?

A new one: Did the tests by other users with the same roles used exactly the same record?

Please confirm that you reset the personalization - I don’t see it explicitly mentioned in your reply. Also consider resetting all usage data.


It only behaves like this for one user and 1 machine. Other users who have the same roles assigned do not have an issue from their machines etc.

They all used the same record.

Personalization was re-set but this didn’t work. I will now try to re-set his usage data.

Do I understand correctly that it works for the same on another machine?

No, the user can log into a different machine and has the same problem. It doesn’t matter where he is logged in he has the same issue on any machine.

However other users can be on their machine and log in elsewhere and they are absolutely fine. It is only affecting this one user.


  • if all the users have the same security settings.
  • The issue occurs in any workstation for the same user.
  • You have cleared the user form personalization’s.

If I had to guess, I would think that you might have some kind of customization that it will hide be options based on a particular user.