The selected record has been deleted by another user (while trying to change item price)

Running MS Dynamics GP 10.0 (yes, I know it’s long in the tooth, but it works!).

I did an update on table IV00108 in SQL Mgt Studio to globally change item prices.

Afterwards, initially no item prices were displayed in Price List Maintenance screen. :open_mouth:

I discovered that in my table update process I had lost all the Indexes, Triggers, Constraints, etc that were attached to that table (I think I know why - I actually would up deleting that table from my database and importing that table from a backup I had made, and I think that’s when the objects got dropped).

So, I ran GENERATE SCRIPTS against a good backup copy of that table to get the code to recreate the missing objects (Indexes, Triggers, Constraints, etc), then ran that code against the table, which SEEMED to work fine - item prices were indeed now displayed in the Price List maintenance window, and I could edit the prices.

BUT - I discovered a few days later that ONLY the user SA can edit prices - when any other user tries to click on a price to modify it, they get “The selected record has been deleted by another user”.

I have stopped & restarted SQL Server, no joy.

Any advice is greatly appreciated!!!

HI Bugman,
I hope you got this solved out as this is kind of late reply… but never ever delete a table in GP, unless you know exactly what you’re doing.
GP tables should only be dropped and re-created thru the maintenance > SQL in GP… where you can select specific tables to be re-created. Or you could use the PSTL function to perform the same kind of operation with the added benefits of keeping the data in the tables (which the other maintenance does not).
In your case, all that is probably missing was the Grant access to the DYNGRP role in SQL, which belongs to all GP users. There is a script in the GP program folder called dyngrp.sql that performs a global rundown on a company DB to grant all user objects the DYNGRP permissions.