The parameter "XXXX" does not exist

I have a very simple SSRS report, it use a query which contains only one table. i create a parameter for this SSRS report. i tried to open this report via the custom class which extends the “SrsReportRunController”.

i got the above error when i run the report from a menu item.

my question is where can i set the value for this parameter programmatically?


i have already tried to set the parameter when i create the custom controller instance in the main method as below, but no luck

ssrsController = new SSRSMyController();


ssrsController.parmReportContract().parmRdlContract().setValue(“Parameter1”, value1)

and i also try to assign the value in the method “prePromptModifyContract()”, but also no luck


Wouldn’t you get "The ‘XXXX’ parameter is missing a value" if the problem was about an empty parameter value?

This sound like if you’re using a parameter that doesn’t exist in the report. Review the report and try to redeploy it to the report server.

Hi Martin,

I’m pretty sure the error is “The parameter “xxx” does not exist”, i tried to set the parameter value by the paramRdlContract.setValue(paramname,value).

and got the above error before, but the param is really defined in my report.

met many tricky problem today,

SrsReportRunController.getfirstQuery() return null ,since the SSRS report data set is based on the query