The Object Metadata does not exist.Identification... Object Type=Page Object ID=1033


When I try to run the RTC, immediately this error prompts,

The Object Metadata does not exist.

Identification fields and values: Object Type=‘Page’,Object ID=‘1033’

I checked the Page object as well as the Object Metadata table, this 1033 does not exists.

please help.

Open the database using classic client and compile Page 1033.

If still you get similar error with an object name, then compile all the objects.

Hi Dhan,

The problem is there is no page 1033 in the object designer.

i’ve checked the standard cronus db 2009 sp1, page id 1033 does not exists…


Then I would imagine it is a problem with the Role Center you are using. Have you compiled all objects to see which ones error out? I would expect at least one of the pages to tell you that 1033 doesn’t exist.

i re-compiled all the objects yet it is still giving me the same error.

the problem is there is no such object 1033 in my object designer.

so i tried to re-install nav 2009 again and try to follow thru the Walkthrough: Accessing Multiple Microsoft Dynamics NAV Databases from a Single Microsoft

Now it is giving me a new error when i create a new service and try to start the service.


Windows could not start the Microsoft Dynamics NAV Server service on Local Computer.

Error 2: The system cannot find the file specified.

I have created the service2 folder,

changed the account to network service

started the Net.Tcp Port Sharing Service

hi, i managed to solve my problem now… my silly mistake…

but still the error remains.

"The Object Metadata does not exist.

Identification fields and values: Object Type=‘Page’,Object ID=‘1033’"

i tried connect to a different database, it works. only for this database, it is prompting me this error.

any idea?

Had the same problem and chanced upon this post.

The reason this problem occurred was due to the absence was any default role center (Administration → Application Setup → RoleTailored Client → Profiles) and no ProfileID set for that particular user trying to open RTC(Administration → Application Setup → RoleTailored Client ->User Personalisation)

Hope this helps someone.