TCP/IP error ecommrefused on Navision 5


I’m having an issue with a new server for a client that is using Navision 5 (they have started using the could but want to keep the Navision 5 as historical data). I’ve installed the nav server on a 2012R2 server and installed client on the same server. I’ve also imported the license they bought.

However, when I try to use the client to connect to the NAV server to create a new database I get “TCP/IP error EOMMREFUSED” I’ve read everything on the forum and can’t find a fix.

Right now the server is not on a domain, but it does have a static IP address.

When I installed the NAV server I used the advance options and chose TCP.

I can ping the server by IP address, as well as by name.

I’ve tried to use the IP address to connect using the client as well as the NAV server name and still get the same error.

The firewall is turned off and there isn’t any anti virus installed.

I’ve added an entry in the host file XXX.XXXX.XXX.XXX database-server.

I know this is an old version of NAV but I’m hoping someone can help. Thanks!

I have the same issue. I’ve been searching for days to try and find a fix for this as well.

Hi, you mention that you’ve installed the NAV server - so the non-SQL version? Are you using the non-SQL client to connect, i.e. fin.exe not finsql.exe?