Hi Floks,

Presentlty i have faceing below issue for one of my Client .

"Therser “DynamicsNAV71” was unable to process the request. Close the application and start again .

Server instance: DynamicsNAV71
Type: System.UnauthorizedAccessException
Message: Access to the path ‘C:\ProgramData\Microsoft\Microsoft Dynamics NAV\71\Server\MicrosoftDynamicsNavServer$DynamicsNAV71\assembly\Page46_421.dll’ is denied.
at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.IO.File.InternalDelete(String path, Boolean checkHost)
at Microsoft.Dynamics.Nav.Runtime.CSharpCompiler.CompileCSharpSourceToAssembly(String assemblyFileName, String sourceFileName, String& errors, Assembly& assembly)
at Microsoft.Dynamics.Nav.Runtime.AssemblyGetter.GetAssembly(ObjectType objectType, Int32 objectId)
at Microsoft.Dynamics.Nav.Runtime.NCLCodeLoader.GetApplicationObjectClrType(ObjectType objectType, Int32 objectId)
at Microsoft.Dynamics.Nav.Runtime.NCLMetaApplicationObject.CompileAndLoadClrObject()
at Microsoft.Dynamics.Nav.Runtime.NCLMetadata.GetMetaApplicationObject(ObjectType objectType, Int32 objectId, Boolean requireCompiled)
at Microsoft.Dynamics.Nav.Runtime.NavFormHandle.CreateTarget()
at Microsoft.Dynamics.Nav.Runtime.NavApplicationObjectBaseHandle`1.get_Target()
at Microsoft.Dynamics.Nav.Runtime.NavForm.TryGetUIPart(String uiPartName, NavForm& form)
at Microsoft.Dynamics.Nav.Service.NsDataAccess.Create(ITreeObject parent, NavRecordState state, Boolean instantiateNewForm, Guid parentFormHandle, String parentControlName, Boolean& instantiatedForm)
at Microsoft.Dynamics.Nav.Service.NSFormBatchOpen.Open(NavSession session)
at SyncInvokeOpenForm(Object , Object[] , Object[] )
at System.ServiceModel.Dispatcher.SyncMethodInvoker.Invoke(Object instance, Object[] inputs, Object[]& outputs)
at Microsoft.Dynamics.Nav.Service.ServiceOperationInvoker.ErrorMappingCombinator(ServiceOperation innerOperation, NSServiceBase serviceInstance, Object[] inputs, Object[]& outputs)
Source: mscorlib
HResult: -2147024891

Version : NAV 2013 R2 CU 51

1.We provide the full rights permission for both account for that folder.
2.We try to run both service with same Account but no output still Client havibg same issue .
3.We uninstall and re-install the NAV in that server.

Any Advise


Hi Subhashis,

Is the DLL in the folder?

Is the dll unblocked?

Hi Sander,

Yes DDL under the that folder and its unblock also .

For testing purposes only could you change the NAV service account to a admin account?

It will show if it is rights or something else

Yes we did that also , But no we got the same error .

Have you tryed importing a clean (From Product DVD) page 46 - Sales Order Subform and compile NAV?

This error came from standard NAV database

Did you re-compile all objects (or list of objects which linked with page 46)?

I so same error when I had problem with “linked page error”

Yes we did it.

Hi All ,

Thanks for suggestion. At present this issue is resolved .

Still root cause is unknown for this case , we create new VM for NAV app server then able to run the client. One thing confirm that It had nothing to do with permissions or Object Compilation.

I suspect that some windows patch causing this issue but not sure …