SSRS page header not shown

Hi how do get to print report header on each page…

thanks in advance

Tablix properties was changed for the table. as above still it is not showing on my 7 pages report

Right-click the design surface of a precision design and choose Add Page Header. Controls in page header are repeated on each page.

But Mr drab i tried it refer screen shot.


I would have known it if you said it before. You’ll save your time and time of everybody else if you provide more detailed description of your problem.

Do you have any controls in your page header? Please try to add a static text there; maybe your controls are there but they don’t have any values or their Hidden property is set to False.

i have a table in report body whose header tabs i am trying to print as it is 8 pages report.

Aha, so even your original question was wrong. You don’t want “to print report header on each page”, you probably want to repeat tablix column headers on each page.

Unfortunately I don’t have any information about what you did (e.g. whether you have any static group to repeat), so I can only show you the documentation: Controlling Row and Column Headings.

You have to enable “Repeat Header rows on each page” on the table properties form for seeing the table header on all pages.


Try to do the following,

  1. we need to set the properties of static member of the row groups.
  2. select tablix and click on the small drop down arrow on the right side of the Row Groups/Columns Groups header. Then select Advanced Mode.
    3.Now select 1st static member. After selecting 1st member, top left cell of the tablix will be selected in the report designer.
    4.Now press F4 or manually open property page. In that, set property RepeatOnNewPage to True. Also set KeepWithGroup property to After.
  3. If still issue is not solved then set FixedData property to True in property page of first static member in row group. It will reproduce table header on every page of report.



thanks martin,anand and raghav

raghav i have to tell u that there isn’t any grouping in my table

Thanks all … raghav it is working now i explored it fully [:D]