SQL 2008 / NAV 2009 Classic : SQLServer cannot be found

When I’m using RTC I have no problems, but when I’m connecting using the classic client then I’m getting this error:

“The srv2\SQLSERVER cannot be found.”

When I’m using the lookup from the client in the server name, then it’s only displaying the SQLserver from the machine where the client is intalled, not from my other server.

SQL Browser is running on srv2. Network discovery is turned on (is that also required).

What else am I missing?


I guess the RTC service is running on the same box as the SQL Server? Which OS are you using? Maybe you need to open the required SQL ports in the firewall: with a “Standard” SQL Instance this should be 1433; a “Named” instance is using dynamics ports: in this case you should change this to fixed one and open them in the firewall …

See also:

Hi Jörg,


I first tried just by adding the program SQLSERVR.EXE to the firewall. Didn’t work!

Then I tried with TCP port 1433. Didn’t work either.

And then tried instead to add the named instance service to the firewall.

Neither worked.

The only thing that worked for me was to completely disable the firewall, and that’s not really an option!

I’m running Windows Server 2008 R2.

Adding the TCP Port to the Firewall should be OK. Have in mind that in case of a “Named” SQL Server Instance you have to switch from “Dynamic Port” to “Fix Port”; in my example I assigned fix port 1434 to my named instance (sorry, screenshots in German but I guess you’ll understand):


Also, you might need to change the “TCP Range” - here “Bereich ändern”:


If this is all setup OK then it should work …

(Once I had the same (?) trouble on my local box and I could fix it that way …)

Thanks Jörg. I actually found out that I just had to add the SQL Browser service to the firewall also. Then it worked!