Scrolling with mouse in Navision

Hi all

I’m pretty new to Navision, and one of the things bothering the most so far is the lack of mouse scroll in for instance the C/AL editor. Is there any way (parameter in ZUP file) to enable mouse scroll?

Best regards from Ramad

I can scroll just fine with my mouse. That’s more of a Windows setting then something you need to do in NAV. Go to control panel, click on the mouse properties and see if you can fix it there.

Hi Ramad,

My mouse scrolls just fine.

Maybe it is in the driver?

Hi - thanks for the input, but it didn’t seem to fix it - sadly. I’ve checked my mouse driver, and even added Navision to my scrollwheel in the mouse options. Then restarted my Navision client, but still no scroll. It’s especially annoying when browsing C/AL code in the built in editor.

hmmmmm, sorry but I have no clue then.

Wich version of NAV are You on?
Maybe it is a bug in the client.

I’m using a few Navision clients and scrolling its working just fine.

But you’re saying that it works in the rest of you NAV client (in other forms), but just not in the C/AL editor?

No - it doesn’t work at all in my NAV client, but I just mentioned the C/AL editor, because that was where it was most irritating. My fellowworkers also have this problem with scrolling.

It a NAV Client W1 3.70 (4.0 SP3).

Hi Ramad,

Actually it looks like it is a 4.0 SP3 client, on a 3.70 W1 DB.

I’ve just tested that setup, and still my mouse scrolls just fine.

What kind of mouse are You using?

It’s a standard usb mouse.

I had this happen to me on my previous notebook. When plugged it straight into the USB ports, it didn’t scroll up and down but scrolled left and right (Code editor only). Really annoying.

When I plugged it using a USB hub it worked fine. I never managed to solve it but I really never tried.

Maybe try searching for an update for your USB driver or using a different mouse.

There was an annoying bug in 3.7 that you had to click inside the C/AL editor before scrolling worked, have you tried that?

So the standard behavior was: you open the C/AL editor, the cursor was at the documentation trigger marker, and was stuck there when you scrolled the mouse wheel. Then you had to actually put the cursor in one of the trigger code sections, and from there on out scrolling worked.

The only situation where I have seen this behavior has been where the clients was not locally installed, but was using Citrix.

I got it solved [:P]

The solution was that the mouse software (Lenovo Mouse Suite) somehow was blocking the scolling feature. I’ve uninstalled the Mouse Suite, and now it works fine. Thanks for all the inputs …

[:D] Good for you!

It’s almost as good a solution like the old one “Did you try to reboot the computer?” [;)]