same Object working fine in sandbox but giving error in LIVE.

Hello All,

I have deployed few report from sandbox to LIVE.

version details are as :

Sandbox -


app.json file detail are


Now one of report working fine in sandbox giving preview

but in LIVE giving error

error is : An error occurred while trying to display the report.

What could be the issue? its very annoying not getting any information from error message. and more on it I do not know VS Code debugging. have to learn it.

Please suggest something. Can I continue my customizations in sandbox VS Code?

Thanks in advance.

I would assume that your sandbox and production tenants are not running the same versions or that the report otherwise does not work in production. Are both live and sandbox in the cloud?

yes, sandbox and live both are in the cloud. Both have same extension version. as i shown in screenshot.

[emoticon:cbb559c4d49d4f5e8918a8a9df61b97e], how many issues I am facing.

While publishing through VS Code in sandbox I am getting error

The request for path /v1.0/sandbox/dev/apps?SchemaUpdateMode=synchronize failed with code 422. Reason:

Multiple published extensions match the specified parameter values. You must specify more information to indicate which extension to use.

Now my scenario is,
when I create my first extension in app.json file , Publisher came Default Publisher , Version Came

  1. I developed few reports in sandbox and then while deploying to LIVE I thought to change Publisher = XYZ Customization. so I did it and deploy it to LIVE. with XYZ file, then for testing I uninstall it.
  2. Then deployment stage comes so I tried to deploy buy I was getting error file with same name exist, I checked in Extension Management window i cant find XYZ Customization_AL_1.0.0.0 there so I thought system might be saving this info internally so I change my extension version to XYZ Customization_AL_1.0.0.1 and successfully deploy the extension in live.
  3. After that I need to do some changes in my reports so I continued with changes. in this I forgot to update my version. as i realise I change version to XYZ Customization_AL_1.0.0.2 and tried to publish in sandbox then got error dependency between extensions. so I uninstall the extension XYZ Customization_AL_1.0.0.1 and again tried to publish now getting above error.

I am working first time on BC. Am I following proper process of version maintaining?
As you deploy the extension my first task should be to update version.

Please suggest what to do now?

Thanks in advance.

for quick rectify remove the extensioon and start over again by creating new project and then publish first in sandbox of course and then to live

Thanks Imran,

from other site I got one more solution:

its asking to use Get-NavAppInfo command, in this we have to use server instance,(Get-NAVAppInfo -ServerInstance XYZ). Now my question is how or where can I get serverinstance name for online sandbox??

it will be blank.

i guess the extension you had uninstalled the one not in use still might need to be unpublish. Always unpublish the extension when you uninstall it.

unpublish the previous version that is!

I Agree, it is the only way of doing it.

I can not see any one of my version in Extension Management that is the issue. it means those are unpublished. If I just uninstall it and not unpublish then it will show in grayed colour. Ti unpublish my previous versions I should see it somewhere.But yes there are other extensions installed which are not mine.

have you managed to run get-navappinfo?

I tried these command, to run this command i need serverinstance name, but I do not know how or where to get serverinstance.

below is my launch and app .json file details

if any other info required please tell.

thought you would you use path of app file to get infor . sorry no idea how to list all apps info on cloud server using powershell but you can see the list in the the extension management on the client. Get-navappinfo all it does list the apps and display related information like version wouldnt rectify the error you are having. You may want to consider my first solution.

Try changing GUID. I strongly suggest you to go through the following video, though it might not answer this particular query but will help you learning things about BC:

Eric, I hope it is OK to share this link here.

That’s very much ok [mention:8b5fe60dd87d4defa88829e964b22a60:e9ed411860ed4f2ba0265705b8793d05].

Thank you very much Dhan Raj Bansal, this was exactly I was facing, it might helped me. But before getting this I opted Imrans suggestion as I it was urgent. I removed the extension , recreate project and started my work Now hope it will work for LIVE. Thanks a lot again.