RTC Client opens on every run in NAV 2015 (R16) and NAV 2016 (R4)

Hi All,

I have the same issue as already described at:


But for NAV 2015 and 2016.

I have already tried the solution there, and 2013 + 2013R2 are working correct.

But In 2015 and 2016 if a do a run of an object from the Dev-Client always a new client is opened.

Im not sure since when this happens but it could be that it was happend by updating 2016 to Rollup 4.

A also tried to add the Default company with noch change of the behavior.

Any Ideas?



follow http://forum.mibuso.com/discussion/62716/nav-2013-nav2013r2-and-2015-side-by-side-installation

Thanks Jonathan for the advice, but this doesn’t help.

On my PC the Registry Link points to:

C:\Program Files (x86)\Microsoft Dynamics NAV\90\RoleTailored Client\Microsoft.Dynamics.Nav.Client.exe -protocolhandler “%1”

I have already tried to change it to 70 but nothing happend.

Also I don’t have the problem that the client doesn’t start, my problem is that the client starts a new instance for every run from the Dev-environment, just like the dev-environment is loosing the connection to the already started client…


you get a new client, if you have startet a runmodal page or report in the actual RTC. I have tested it in NAV 2016 (CU4).

What happens, if you do this?

  • no RTC is running

  • run a report of the development environment

  • close the requestpage, but the rtc is still open

  • run the report again of the development environment

Do you get a new rtc or opens the report in the existing session?

best regards


Hi Robert,

i know, if a runmodal page is still open you will get a new instance of the RTC.

But in my case no modal page is open.

I did the follwing test:

  • Run Report 1 (chart of accounts) - close the request page.

  • Run Report 1 again.

  • Run Page 1 (Company information) - close company information page.

  • Run Page 1 again.

  • Run Table 3 Payment Terms - close the opened table.

  • Run Table 3 again.

After that I have 6 instances of the RTC open.

I usually get the message that this not my standard connection when I start the client, so i thought this could be the reason.

I fixed this in the ClientUserSettings.config so that the RTC starts without any warnings, but this also doesn’t help.

so far thanks for your help, it seems that I am the only one who has this problem.

follow http://dynamicsuser.net/blogs/vanvugt/archive/2016/03/08/nav-2016-multiple-clients-launched-when-running-objects-subsequently-from-object-designer.aspx

The Solution behind the Link in Ivans Blog worked perfect, thanks for your help!