Report parameter missing a value

Hi i get this error when i run report


How to resolve this … thanks in advance

you might have passed parameter in your contract class.

So to run your report , you first have to enter parameter value .

i did … and also i set nullable and allow blank to true and checked still the same

ok /…then try to follow the steps as mentioned below : -

  1. Open the report for editing in Visual Studio.

  2. Expand the Parameters node and rename the affected parameter to ParameterName1.

  3. Set Allow Blank and Nullable to True if not already set.

  4. Deploy the report.

  5. Rename the parameter back to ParameterName.

  6. Deploy the report.

Thanks Mayur [:D] It worked But then i would like to add few points to it

when i tried rename whole new set of errors started popping up …

So instead set properties to true Deploy it then complie all SSRS class,generate Incremental CIL , restart SSRS service then deploy ur report again and run it

It works perfectly fine

welcome [:D]