Report not printing


I have this rather strange issue with a report. This problem exists with only one user.

A user on our system can’t print this particular report. This is happening with this user’s login only. I’ve tried to print the report using my login credentials on the same pc and works fine. But the other user can’t print or print preview the report. Other reports print fine with the same printer with the same user on same pc.

We use windows authentication and its NAV 5.0. I’ve removed the user from NAV system and added back again with same roles and synchronized. Nothing works.

Any ideas on what could be the possible cases and any solutions?


Take a look at Printer Selections (NAV 5: Administration → “Application Setup” → General → Printer Selections")

Try to run the report directly from Object Designer

Look into the report itself: is there something that prevent that user from printing?

Also possible to activate debugger to whatch the progress…

Do you get some error related to permissions for this user while running the report?

Thanks for the replies. No error msgs are appearing. I’ve tried the printer selection window and all setups are ok. Tried to run the report from the object designer as well…only this user has the problem.

No code level modificaions are done to the report.

help please !


But WHAT exactly happens when you press Print…? You wrote - no message pops up…

Does Printer selection dialog open?
Or does Report dialog just closes with no further actions elsewhere?

If it was with ALL reports, it should be Printer gone off-line & all printjobs sitting in Print Queue, but only with one separate… But just in case check Print Queue - you might have set up for that report/user an Envelope Tray or some empty tray (if printer has many of them), so it simply waits for you to insert paper there…

added: As last resort - remove elsewhere user’s ZUP file, and try then (don’t delete it, so if it does’t help you can put it back, thus not loosing user’s settings)

Try Modris’ suggestions.

  • Is the report executed at all? Did you try the debugger? By using debugger you can step through the NAV-code - perhaps a “hidden” command such as CurrReport.QUIT or ERROR(’’) occurs; ERROR(’’) causes an abortion, but without any message.