Purchase Order editing issues after approval


Any can tell me why Purchase order is showing different behavior based on the workflow which is used.

I can edit an approved/confirmed Purchase order which is released from Purchase Requisition. But I am unable to edit an approved/confirmed Purchase Order which is not released from Purchase Requisition (directly created PO) .

Best Regards,

Have you enabled the ‘Activate change management’ in procurement parameters?

Hi Kiran,

Thanks for your reply.

Yes, ‘Activate change management’ is enabled. But my question is why Purchase order is showing different behavior based on the workflows used.

I can edit the purchase order (after all the review/approvals) if I create a purchase requisition and release to Purchase order (after purchase requisition workflow review/approvals)

But I can’t edit if I create a purchase order directly (without purchase requisition) .

Best Regards,

There must be some customization around if you are trying to edit the PO before approval, i.e., in the status Draft.

The reason I had asked you about ‘Activate Change Management’ is because if it is activated and PO workflow is defined & active, the user will not be allowed to change the PO after approval and Request change form should be used there after for any changes to PO.


Have you tried working on a PO which is created from PR? If so, is it the different behaviour that you are seeing? or same as what is mentioned?

Hi Santosh,

Yes, I have worked on PO created from PR but not with ‘Active change management’ enabled.

As per my knowledge the behavior is normal like as you directly create PO. But seems here the case is different if i understand correctly.

There is no single piece of customization.

There wont be any difference. Try to debug the code and see why it behaves differently.



\Data Dictionary\Tables\PurchTable\Methods\editAllowed