Production Order Error


When I tried to end the Production Order I received an error that the financial dimensions must be specify.

all the financial dimensions of the BOM have been specify.

any help.

Check the BOM against the WO, also check the route - the error tells you the account, this helps you identify the process and where you need to define the dimension.

I checked the WO BOM and also the route, dimensions are already there

When I traced the error it looks like it happens during posting a Voucher but all Vouchers related to the order have dimensions.

Did you check the dimensions of the production order itself?

Clearly not, unless you have modified it!

The error will tell you the account in the infolog if it is a dimension error, trace the code to the posting group and establish the requirement.

dear AdamRoue,

Actually this error happened because the user added new item to the production order BOM Lines (ProdBOM table) without dimensions and when he posted the BOM journal (ProdJournalBOM) he assigned the dimensions so if you check the item in the ProdBOM you will not find the dimensions and when you check the item in ProdJournalBOM you will find the dimensions, so I updated the dimension for the ProdBOM from the backend but it doesn’t work because I think another Vouchers have been created after the BOM has been posted.

If I deleted that item from the BOM lines the Order can be ended but I think the Order cost will not be right.

So they added this mid-process in a dimension driven requirement, still the same issue there was a BOM item with no dimensions, the obvious place was the ProdBOM but we were still pointing you to where the error was without much detail of the issue. The financial transaction into WIP is made at the point of posting the journal if the user entered the dimension this part is not correct. This would then imply your RAF journal has not got the dimensions, so I do not believe the user adding it, defining a dimension and posting it is your issue. perhaps you are trying to backflush material as well as RAF, I cannot tell from here. You could try resetting the order and running through it again. The item is not in the ProdBOM and adding it to the journal and posting it will not cause issues. Therefore your error is something else, but you have not posted the error so it is difficult to say. I would still check the account defined in the error message, but little else I can do from here, basically the system at the point of RAF is insisting on a dimension due to your configuration and you are not providing it, a successfully posted pick list journal will not be the cause of this (depending upon your finish parameters).

Problem has been solved, after I updated dimensions in ProdBOM and InventTransPosting.


Your support is highly appreciated.