Problem with the numeric period key when using Dutch settings W7

When entering numbers on the number keypad the numbers show up with a comma instead of a point when utilizing the point so the number shows as 000,000,010,0001 instead of or P106751,01,01,01 instead of P106751.01.01.01

This behaviour of the numeric period key started after we installed hotfix Hotfix KB2900018-SP1 to solve a different issue. Seems that the hotfix did not take into account that large parts of the world use a comma as the decimal seperator instead of a period (setup in Windows). Uninstalling the hotfix is not really a option, as it solves a different problem that influences daily business a lot as well. From a Dutch partner we have heard there are several more customers in the Netherlands who suffer from the ame issue (depending on their kernel version).

Our partner submitted the case to Microsoft, but denied it saying the behaviour is ‘by design’.

Has anyone here had this issue and more importantly: did you get it solved and how?

If you know of the problem but do not know a solution yet, our partner has opened a ticket that Microsoft partners can comment on with their microsoft account. If it gets enough comments, Microsoft will consider to change it. So if you can not help us with an answer to the problem, you could still help by commenting on this ticket:

Any help is appreciated!