Problem with SMTP (CU 400) and webservices/RTC

Hi Guys,

We are currently experiencing a very weird problem and I wondered if one of you ever had this before.

For a customer we implemented an application that approves NAV-documents through webservices (with the existing NAV-logic → approval management, smpt, …).
Users can approve, delegate and reject documents from this application, so sometimes it is needed that an e-mail is sent to another user.

Everything is working fine most of the time, but for one reason or another the application starts blocking on the sending of the e-mail (e-mails were also sent with the application shortly before). The following message is returned from NAV:

The SMTP mail system returned the following error: (0x80040605): Unknown Error

If I open the RTC-client and want to perform a manual approval request (including sending of e-mail) I get the same message. In the classic client everything is working fine.

The error is solved from the moment I restart the service tier (Server + webservice).

Anybody any idea what is causing this or how this can be solved ?
I’m getting a bit desperate :-).

Thank you very much in advance.

Kind regards,

Hi Tom,

This may sound as a silly question, but did you check if the virus scanner is blocking the sending of e-mails by external applicatiions? I ran into this problem myself when using the SMTP cu 400.

The customer in our case was running the enterprise version McAfee and that didn’t give a clear warning except a message in the log.

Thank you for the reply Marco.

As far as I can see no virus scanner is installed on the server but I will check with the IT-guys.

Did you have this problem on RTC/Webservices only ? Or also in the classic client ?
If I try to send an approval request from the classic client on that same server…everything is working fine.

Strange…Very strange.


Hi Tom,

In my case it was on NAV 2009 Classic.

Hi Tom,

Long time since you posted this thread, but I’m having the same issue with a NAV2009R2 installation for one of my customers.

Did you solve the issue in the end, and can you tell me how?




could be a relaying problem depending on the mail addresses.

did you find a solution in the meantime ?

In my case, issue solved by changing the code in CU400, thus forcing SMTP to be sent from the client instead of the NAV service tier:

thx for the info.