Posting Suggested Payments doesnt Apply Entries

Our client has had a problem with a payment journal. They populated it using the suggest vendor payments batch job. This journal posted but then the user received the message “Application was successfully posted although no entries have been applied”.

If I go into the vendor ledger entries form I can apply the payments to the invoices manually. The payments and the invoices are all in the base currency. The user has successfully posted payment journals before …

Has anyone got any idea what might have caused this ?


On investigation, the payment ledger entries have peculiar values in the “Applies-to ID” field. The “Applies-to ID” seems to be the same as the “Document No.” !! These were BACS payments and the “Document No.” values are sequential numbers starting at ‘1’ (ie ‘1’, ‘2’, ‘3’ etc.) It makes no sense for the “Applies to ID” to have the same value as the “Document No.” but it does. I have checked and there have been no amendments in this area.

Actually I see this is standard functionaility. The “Applies-to ID” is fine [:$]. So I am back to asking if anyone has any idea what might have caused the applications to “fail”.

Aha. This seems to be a problem with all vendor applications … but only for one user. The same user who had the problem with the payment journal also cant apply posted vendor ledger entries. She gets the same error message in both cases. Other users can apply the entries that she cant. She is not a new user and appears to be operating the software correctly. I would be really grateful for any theories …

Can the user go into the ledger entry and apply the transactions manually afterwards?

No. She cant do manual applications either.

That could imply a security issue, but my bet is it is the user. Have a user that can do it take over her terminal and apply transactions that she cannot - if she can do it then it is processing, if she cannot it is rights (but I would have expected a different message)

I have now watched her and am reassured that she is processing correctly, I have also posted applications using her login with the same results. I was using our dealer license and had given her superuser rights, with no effect !!

I have tried debugging to see what is going on but dont get it !?! I assume the issue must involve her user ID, perhaps in relation to the “Applies-to ID”, but maybe I am overlooking some other possibility,

Hi Bob,

This sound strange indeed - only thing that comes to mind is the application date is not in the users posting date range

Hi all,

if this is still a problem. We solved that by showing the hidden field remaining amount in the vendor ledger entries page. When showed up it is then calculated and the apply worked for all users.

Or changing CU227…

CU227 ApplyVendEntryformEntry(…)
ApplyingVendLedgEntry.“Applying Entry” := TRUE;
ApplyingVendLedgEntry.“Applies-to ID” := VendEntryApplID;
ApplyingVendLedgEntry.CALCFIELDS(“Remaining Amount”);//**

We only displayed the column and it worked.