pivot table on Windows 2000 pro

Hi, Reading pivot talbe is working fine on all XP pro machine. However, it’s generating “Pivot table is not available” error message on clicking inquiry->pivot table from Windows 2000 Pro. As instructed on help, I installed microsoft query and reading pivot table from external server is fine in Excel. But reading pivot table in axapta is still getting erros I though this is related with importing ActiveX(Microsoft Office Pivot Table) into Axapta because all the working PCs have this activex while failing PCs don’t have this one. I updated ms office but couldn’t see ‘microsoft office pivot table’ from axapta and got same error message. How can I download this ‘microsoft office pivot table activex’? or Is there any other way to circumvent this problem? Thanks, Dave

Hi Dave, AFAIK, the Dll responsible for pivot table etc are collectively called as Microsoft office web components and this can be installed from MS Office CD. In older version of MS Office, the dll was called ‘MSOWC.DLL’ and by default installed under System drive:\Program files\Microsoft office. In any case, if you want to check whether OWC is installed correctly - 1. Go to Excel 2. Click Data then Pivot Table and PivotCharReport 3. Choose External data source, then Get Data 4. On the Choose Data Source, click OLAP Cubes 5. Create a new data source. Enter all the required parameters 6. Click OK and then Finish. If everything is right, a valid Pivot table would be displayed. Also looks like this can be downloaded from - http://www.microsoft.com/downloads/details.aspx?FamilyID=982B0359-0A86-4FB2-A7EE-5F3A499515DD&displaylang=en Hope this helps, Harish Mohanbabu

Thanks, Harish. According to your suggestion, I did two things. 1: generating pivot table from external DB source => fine. 2: I downloaded, installed the web component, and rebooted the computer. Now I got DIFFERENT ActiveX Error messages. They appear in the order presented below. ######## Error msg 1 ### Unable to create ActiveX control. (ClassID: {0002E520-0000-0000-C000-000000000046}) Is not found on the system, please check if the control is correctly installed ######## // click OK // ######## Error msg 2 ### Unable to call method on activeX, wait until object is fully initialized ######## When I import ActiveX from form->design, I can see that ‘Microsoft Office Pivot Table 10.0’ has been installed from the web component installation. But still before and after importing ActiveX, error messages are same as described above. I’d appreciate any help. thanks, Dave

Hi Dave, What version of MS Office have you got? Also have you tried unregistering and registering MSOWC.DLL using regsvr32? Regards, Harish Mohanbabu

Hi, Currently, Microsoft Office 2000 SR-1(MS Office 2000 Small Business) is installed and updated after installation. For testing, I removed Office 2000 and installed XP standard. It’s working fine. But my company already deployed MS Office 2000 Small Business. I can’t change this at around 100 computers over many sites. Even after installing Web Component, local system doesn’t have msowc.dll so It seems like I can’t use regsvr32. Best, Dave

Hi, It seems like the XP Web Component didn’t work with MS Office 2000.(as has been said at the linked page in Harish’s msg above) I removed it. But anyhow, I found a way. Here is what I did. I copied MSOWC.DLL from MS Office 2002 installation to “(MS Office 2000 installation dir)\Office” directory on the failing PCs. regsvr32… and then it seems like Axapta pivot table is happy with this DLL file. Pivot table is working fine. I am hoping that Excel 2000 will work fine after this forceful copy of MSOWC.DLL from Excel 2002. I tested creating pivot table in Excel 2000 and it’s ok. Thank Harish for appropriate question and advice. Best, Dave