'Ower ID' field missing in RTC Profile Card

Dear Experts,

NAV Version: NAV 2013 R2

I am currently trying to hide the Departments button at the Navigation Pane of RTC. I understand that we can enter the configuration mode of certain RTC profile and hide it.

I use the following command at command prompt to enter into configuration mode:

Command 1: cd C:\Program Files (x86)\Microsoft Dynamics NAV\70\RoleTailored Client

Command 2: Microsoft.Dynamics.Nav.Client.exe -configure -profile:"Order Processor"

I also read from MSDN library that only the owner of the “Order Processor” profile is allowed to enter into the configuration mode and hide the Departments button at the Navigation Pane of RTC.

The problem now is I do not see the field ‘Owner ID’ in NAV 2013 R2. Please refer to the following link for the print screen: postimg.org/…/

In this case, anyone will be able to enter into configuration mode and enable the Departments button.

May I know how can I restrict only specific person for example admin allow to enter into configuration mode?

You can not restrict the permission for allow/disallow the configuration mode to anybody as it is run outside the application.

If anybody found the command on MSDN then he can use that command and follow the steps .

Dear Amol,

Thank you for replying to my enquiry.

Actually the question I ask is based on the following link:


It is written "If you are the owner of the profile, you can open the RoleTailored client in configuration mode for that profile. Changes you make to a Role Center in configuration mode apply to all users associated with the profile."

I have cross checked with NAV 2009 R2, indeed there is a field called “Owner ID” in table Profile (ID: 2000000072)

So, does this mean that only owner of the profile is allowed to open NAV in configure mode?

Hope to hear from you soon. Thanks!

Hi Navision Experts,

Does anyone have any idea on this topic? I hope someone can enlighten me or give me some idea on this.

All your time spent to read this topic is really much appreciated!

Thanks in advance.

This is strange I have been studying for the 2013 exams, I checked in 2009 and the field is there on the profile page/table, in 2013 and 2013R2 the field is not on the page or the table so I really don’t know what to say except make your changes then set it disable personalization to true, when you need to make changes set it to false and make the changes. I did not test whether I could make changes with the cmd flag on the exe despite user personalization being disabled.