Overflow under type of conversion text to text


Can I know the why the fellowing error will come.

Overflow under type of conversion text to text

Value : it showing the Item description .

My Observation is

In Item table :

Description field : 30

Purchase line table :

Description field : 50.

In item card I created a new item = 123456789012345678901234567890( totally 30 characters)

In purchase line Item description field

1234567890123456789012345678901234( 34 characters), I increased the value manually to 34 characters.

When I try to post the purchase order for receipt this system is throwing the error.

It is showing the item description.

So let me know why the reason.

I guess that you have some modification in e.g. codeunit 80 or 22 - perhaps the item’s description is changed according to the purch-line’s description. Or the description is copied into a variable.

When posting a purchase the item’s description is never changed - not in standard NAV, as far as I know.

If possible, activate the debugger (“Active” checked, “Breakpoint on Triggers” un-checked) and try to post again - now the debugger will be activated and show you the line where the error occurs.

What is the error message that you are seeing?

Thanks David ,

When I try to post the purchase order it is showing the message is

Microsoft Dynamics NAV

Overflow under type of conversion text to text

Value : Loudspeaker 100W OakwoodDeluxe black


This is error what system throwing .

So basically you entered " Black" into the description field on the Purchase Order Line. This should be possible. So it might be a bug in your specific version. I assume that you can reproduce this in a standard Cronus database, but which version are you using.

Which version of NAV are you using ??

Have you tried to trace the source of the error by using debugging tools??

I have tried it NAV2009 IN but system does not give any error which you mentioned …[:P]

I would suggest to try Anfinnur’s suggestion to activate the debugger.

This error comes, as others have stated already, if you try to put too much text into a place that it doesn’t fit.

Basically we know that the 50 char’s allowed in purchase line is too much at some point through the posting, but we have no idea as to where it is.
There is a lot of entry-tables being hit by the posting routine, and every one of them has a description-field.
Or as Anfinnur also says, it could be put into some variable at some point, that is too little.
In essence it could be anywhere in the DB.
The most likely place is to look at some modification or localization, since this is not an issue in a standard W1.
But the far easiest is to use the debugger to pinpoint the exact line of code that causes the error, then change that line of code to use COPYSTR combined with MAXSTRLEN to make sure this doesn’t happen again.