Opening SSRS Report using Contract Class Without Controller

While Opening SSRS Report using Contract Class Without Controller in ax2012R3 i am getting Field doesn’t have in this Datasource … originally invent test Group member doesn’t have this Field

I have checked contract class it does not have validations and it contains only Two parameters fromdate and To date

for this i have lot times restat AOS ,SSRS Service after Apply Different Types of Experiments

but This Problem was not Solved

But I found That problem was in Query because through visual studio i put dataset dynamic filters Property set NO.. Then report dialog BoX opens but i need to use dynamic Query in my Report Dialog box

please help me out …

Open the report in Visual Studio. Refresh the data source. Preview the report to see whether it works.

(Moved to the Developer forum; tags added.)

I have Done Dataset Refresh also But its not working in Visual studio Preview its showing but i am not getting any data (just design appears )

Hi Friends

Please help me out

That you don’t see any data may be an unrelated bug of yours.

Have you redeployed the report? Are you able to find out where the error is thrown? Did it work before? If so, what has changed?

Yes I have Deployed Lot Of time but System throws Same error… this type of problem first time i have faced. when i put a breakpoint on opening classes of Report dialog i am getting an excepion from sysloading but i have deleted all cache

values … and Restart aos , SSRS also but it throwing same error


yes I got Solution I think this is last value problem(Cache) but i have deleted all cache values but i am getting same error …

any how i got permanent solution for this cache problem

just skip 29 line while debugging

your dialog will open fill up all details in dialog to store successful cache value

then re open dialog u will get perfect Report dialog box