Open database with several fdb on hand

Who is able to give me the correct syntax for opening a database where I have copied the several FDBs from a DVD? I tried the following statement in some variants but did not suceed:
C:\Programme\Navision201ADE\FIN.EXE database=“F:\XX\XX_DB_201\XX3.fdb+F:\XX\XX_DB_201\XX4.fdb+

Put all files in a subdirectory that is easy to get to (a short one).

C:\Programme\Navision201ADE\FIN.EXE Database=F:\DB\XX1.fdb+F:\DB\XX2.fdb+F:\DB\XX3.fdb+…

No quotes:

C:\Programme\Navision201ADE\FIN.EXE database=F:\XX\XX_DB_201\XX3.fdb+F:\XX\XX_DB_201\XX4.fdb+

And as Alain says, keep the names simple.

I also tried without quotes, different quotes, …
As mentioned by Alain I will try to use shorter pathnames later, but I would like not to have databases just in a root directory or so. I will report back…

I will try later, thanx.

it was indeed the length of the string. Even the subdirectory F:\DB did not do it. I had to build the database in the root directory of the hard disk, maybe because it consists of 7 seperate 2GB files.

Never tried this: try to rename the DB-files so they are shorter. In this way you can put them in some subdir. But like I said, I never tried it.

Actually I did rename the files because otherwise it did not work. Not to repeat the whole string but it looked like: … database=F:\e3.fdb+F:\e4.fdb+ … I think this was because I had 7 files to connect. It even did not work with a DB subdirectory. One should know how long the parameter string was designed by Navision (at this time it was NOT Microsoft [:)]).

I did sit down once and work all this out, but now can’t find my notes. Basically though there is a limit to the string length, and that is the entire string, including the word FIN. And I think that it is a DOS limit, not Navision.

Anyway, there are some other work arounds. Three that I have used, sometimes they work, sometimes they don’t

The first, is to install the server with the name of the first file as the database, this will create an error if you try to start. But then go to reg edit, and here you should be able to enter the F:\XX\XX_DB_201\XX3.fdb+F:\XX\XX_DB_201\XX4.fdb+ string. I found this by accident when trying to fix the old 2.00 error with double-double quotes in the registry (i.e ““c:\database.fdb””) Which by the way is why I thought maybe your issue was with the quotes.

The second I assume you are using a “DOS prompt” to start Fin. If you do it from a short cut, its seems possible to use more characters than from the DOS prompt, so do that instead.

Another is that since you have all the files in the same directory, (I assue a local test DB). Change directory to F:\XX, and try the command :
F:\xx\ C:\Programme\Navision201ADE\fin.exe database=db1.fdb+db2.fdb+…

The nice solution would be if we had a window much like the Expand Advanced screen where we could select each database part. But since we are moving to SQL, we know that that is not going to ever happen.

A little off topic:
And we will never ever see such nice functions as “dbGLOBALFILTER” again. Very sad.

To stay off topic: And we need the function back to find out which variables in an often changed object (T37?) are still used and which are obsolete. [:)]
But we got used to the function names, not having the dbxxx at the beginning. Another [:)]

Yes that was a great function.

By the way, I can’t be too specific, but we are getting a couple of DOS features back in 5.1, features we thought lost for ever.

I really didn’t think this string was too long, so I just created a database like you have (except on C: not F:), and I was able to move the files all to a new folder, and then open the database just by goiing
File → Database → Open and entering
C:\XX\XX_DB_201\XX3.fdb+C:\XX\XX_DB_201\XX4.fdb+C:\XX\XX_DB_201\XX5.fdb+C:\XX\XX_DB_201\XX6.fdb+C:\XX\XX_DB_201\XX7.fdb+C:\XX\XX_DB_201\XX8.fdb+C:\XX\XX_DB_201\XX9.fdb in the database name field.

I alsways thought the string limit was 250 or something in that area. (not a round 256, or 128 but a little less than one of those).

Now if I enter:
“C:\XX\XX_DB_201\XX3.fdb+C:\XX\XX_DB_201\XX4.fdb+C:\XX\XX_DB_201\XX5.fdb+C:\XX\XX_DB_201\XX6.fdb+C:\XX\XX_DB_201\XX7.fdb+C:\XX\XX_DB_201\XX8.fdb+C:\XX\XX_DB_201\XX9.fdb” i.e. with quotes, I get the error message. I think the initial problem was as I said, the quotes.

I was just thinking, anther thing. You are connecting to database name xx3.fdb. Is it possible that really the db name is xx1.fdb, and somewhere you lost xx1.fdb and xx2.fdb?

thanx for still testing on a Saturday. [:)]
I did not try to enter the data with doing: file>database>open. I created a *.bat file and finally succeeded with the short filenames as already mentioned. But this is a thing we can take out of this thread: it better works this way.

Nope, it really started with xx3. I first had the same suspicion when I got the files… But as mentioned earlier I was able to connect th files then.