Only one production order with multiple lines when use MTO (make to order)


When i use manufacturing policy in item/SKU card as MTO(Make to order) & if i plan multiple level production orders then system (NAV 2009 R2) will plan only one production order with multiple lines.

But same scenario did on NAV 2013,

It planned same thing but deference production orders.

Any one note that situation? is it improvement in NAV 2013?

Hi Tanya,

This works the same in NAV 2009 as in NAV 2013, are you sure that you’ve also set the Reordering Policy to Order in both versions?

Hi, thanks for the reply,

Yes, all the parameters set as follows in both versions,

  • Manufacturing policy of item/SKU cards = MTO
  • Reorder policy of production items= Order
  1. What should be the correct way ? whether separate orders or one production order with multiple lines?


With this setting NAV should create one production order per sales order. And if the primary BOM consists of components which again are set to MTO and Order, then their productions order will be created as part of the primary production order. No differences here from NAV 2009 to NAV 2013.

Well Tanya I still fail to see the error. Please explain me what you think that the error is. That it works different in NAV 2013?

Hi , thanks for the reply;

I am saying,

When manufacturing policy=MTO & reorder policy= Order in Item/SKU cards,

When run planning worksheet, System (NAV 2013) will create multiple level production orders with deference production order nos, (See above picture)

Its ok for me.

But same thing when i did on NAV 2009 its create only one production order with multiple lines. Its also OK.

I want to know this deference because of my setup issue or some code changes in NAV ?

if you want ,i can provide more details,

Thanks lot again

Hi Tanya,

Thanks. I was just a bit unsure which of the two setups you were looking for.

But yes, the difference in the two results is to be found in the setup. But without having access to your system, then it’s impossible for me to say exactly which setting is wrong. As a developer I would normally turn on the debugger and see exactly which setting is doing the difference.

If you don’t already have a “test company”, then I’ll also suggest that you get one created. A test company is basically a copy of your current live company but made in the same database (or if the company is very very big, in a different database).

When working with the different item parameters it always a good thing to be able to have a “play ground” where you can just change the items, without having to think about if you messes up something else. Even though I have worked with NAV for over 22 years, then I always create a test company, because I always want to test the different setup changes, if I’m not 100% sure that they work the way I expect them to.