Not secure http://localhost:8080/DynamicsNAV110 to https://localhost:8080/DynamicsNAV110 (HTTP - HTTPS)

Hi Team,

I read and follow this link but I don’t achieve it.

I have generated my SSL Certificated but I can’t connect with this below:


  • In the <system.webServer> element, add the following elements.

<rule name=”Redirect to HTTPS”>

I need your assistance,



Certificates is not the easiest part of installing NAV!

SSL certificates are used to “replace” the standard HTTP port 80 with the standard HTTPS port 443 - as long as you have followed the standard way of setting it up.

You cannot use port 8080 with HTTPS, it would be https://localhost:443/DynamicsNAV1 - but you don’t need to specify :443, as that’s implicit. The only reason you specify :8080, is because it’s not the default HTTP port.

Plus you would not be able to redirect 8080 to 8080, if that’s what you’re trying to do.

These are what I have done with there result.


The desktop version is working likewise http://localhost:8080/dynamicsnav110/ but https://localhost:443/dynamicsnav110/ what I want to achieve, Thanks

Your added screendumps are in a low quality so it is hard to see what you have done.

What does it say on your upper left corner when you click on the lock? (to see the certificate) - If there are not certificate added you can have three issues

Your CName in your certificate does not match your computername and/or your domain (localhost)

Your DNSIdentity is wrong compared to the name of your Certificate.

Your Certificate has not been installed on the computer as Trusted Root Certificate

Finally your second website (443)was it created with tht power(s)hell command New-NAVWebServerInstance ?

I sincerely appreciate your replied.

1.) CName in my certificate = DESKTOP-T6U5FJC.NAV2018.local, Computer Name = DESKTOP-T6U5FJC.

2.) In the ClientUserConfig,

In the NavSetting.Json, “DnsIdentity”: “DESKTOP-T6U5FJC.NAV2018.local”

3.) Yes, show below

4.) I only created binding of 443 through IIS.

Please guide me on how to create it, Thanks


Please can you share with us Server Windows Logs from your NAV server instance, so that we can see what the issue is.

Read this on Certificate issuing and applying SSL connection settings. (it is for NAV2013, but SSL certificate setup is done the same way…ir relaly similar…

You will need to configure also IIS and make sure that you have installed all certificates and make sure thumbprint of SSL certificate is correctly inserted on NST (I think it cannot be copied, but manually typed in).

I have once written down all the steps for NAV2018, but I cannot find the PDF document:(

Thank you
BR Damjan

Check this link

I found my NAVUserPassword and SSL certificate installation guide. Do you have any email address where I can send you the installation guide?
It’s was used at one of my clients, so I would like to send the user guide to you, not to post it here on the forum…

Thanks Damjan

I appreciate your reply, below is the server instance

Wow that is beautiful. Email Address: or

Thanks is for desktop version not web version of Microsoft Dynamics NAV.

The desktop version is working perfectly except the web version



I just sent an email with PDF file.
I believe you need to set Credential Type to NavUserPassword to use SSL Certificate authentication, but I am not 100% sure of this.
Just check the PDF file and make sure SSL settings are configured according to the settings in PDF file and try to open web client.

Thank you
BR Damjan

open the web client and copy the error form event log of the client computer and the NAV server, if there are any.
WE need to see the full error on web client.

I think you are pretty close to be there… In order to see the final step we need to get the error message that you are given - You can see that in the Event Log for the servicetier you are using.

If you are using two different servicetiers then it might be that the servicetier user is not added to the database. But again, lets see your event log error message.

I appreciated your replied, I have done according to your guide, could it be because am using Username instead of NavUserPassword.



You should actually use NAVuserPassword - You bitmap is to small to see, and again we cannot help you further unless you present the event log error message.

Yes, set it to NavUserPassword, and make sure certificate thumbprint is inserted.

Make sure that user account that runs NST has full permissions on the imported SSL certificate(s).

  1. On the server where your servicetier is (where NAS or NST is running) open Certificate Manager by windows key+R and type in certmgr.msc
  2. navigate to imported SSL certificate(s) → right click on the certificate → All Tasks → Manage Private Keys
  3. select user account that runs the service tier (NST) and enable full control (below printscreen is just for your reference).
  4. Restart NST
  5. open Web Client
    Perhaps you will have to restart IIS, too…

Thank you
BR Damjan

When it’s come to forget password, how can I treat it


What password? If you mean the user password then an admin can go ind Dynamics and look for USERS and choose change password.