Not able to connect RTC client.

I have installed NAV 2009 R2. Classic server and client are connecting to server but RTC client is not connecting. I have entered server address " localhost:7046/DynamicsNAV " but it is giving error.

In CustomSetting.config file there is proper server name and port number.
But when i goto cmd prompt and check the listening ports (netstat -na), it is not showing 7046 port number in the list.

Could anyone please guide me on this issue.

Thank you,
Savan Disawal

is it a client - server environment or installed on your PC?

It is installed on VHD.

Can you explain what is VHD?

Is your database on same system or somewhere else?

It is Virtual Hard Disk…and the NAV is installed on this Virtual Hard Disk.

Is your database on same system or somewhere else?

What is the error?

Yes, database is also on same machine. In RTC , select server window, after entering Server Address as " localhost:7046/DynamicsNAV" it gives error message insted of populating companies.

Error is" A server was not found at “net.tcp://localhost:7046/DynamicsNAV/Service”. Either the URL is incorrect or server is not available. "

Kindly help to resolve the issue.

Thanks,

Savan

Go to Services and check whether Microsoft Dynamics Server service is avialble and is running.

The service “Microsoft Dynamics NAV Server” is there in services but its status is showing blank.
And when i start this service it gives me message “The microsoft Dynamics NAV server service on local Computer started and then Stoped. Some service stop automatically if they have no work to do…”

Can you please suggest if this behavior is correct or there is problem with services?

thanks,

Savan

Change the logon setting to Local System Account in Microsoft Dynamics Server service and try

Tried this but got the same error. Now I am trying to repair RTC client by reinstalling.

If any other possibilities are there then please let me know.

You can google with the error message…there are lot of posts with the same problem…

Reinstalling the service may solve your problem

SOLVED :slight_smile:

Did little bit cheating :wink: Even after re-installing it was not starting Microsoft Dynamics NAV Server services, So copied “Service” folder in C:\Program Files\Microsoft Dynamics\60\ " from another PC and rebooted VHD… And finally RTC client opened without any error.

Thank a lot for your help :slight_smile:

Savan Disawal

If your customsettings file is wrong then also you will get this error…

Ohhh…Yes, it was problem wid config file…insted of replacing Service folder i could have replaced config file to solve this issue.

Thanks :slight_smile:

Welcome [:D]